Bug in gzip (package wintools.windows)

Daniel H. Luecking luecking at uark.edu
Mon Apr 17 20:50:32 CEST 2023

For every self-update of tlmgr (so far) I have gotten the following error message from windows (Win 10):

  gzip.exe - Application Error
  The application was unable to start correctly [0xc000007b]
  Click OK to close the application.

I could reproduce the same error under Win 7.

To make sure it was not me at fault, I disabled each locally available version of gzip one by one (and waited for another self-update to arise). Finally, I thought to look for a version of gzip supplied by TeXLive and found gzip.exe in the bin/windows directory. Executing it directly caused the same error, as did gunzip.exe.

Replacing them with locally available versions made the error go away. I also tested the other programs in wintools.windows (just executing "<progname> --help") and found no other obvious problem.

Oddly, all of the self-updates seem to have succeeded without a working gzip.


Daniel H. Luecking [luecking at uark.edu]
Department of Mathematical Sciences
1 University of Arkansas
Fayetteville, AR, USA 72701-1201
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/tex-live/attachments/20230417/2a3906f2/attachment.html>

More information about the tex-live mailing list.