[tex-live] Errors in installation via install-tl

Henrique Lengler henriqueleng at opmbx.org
Tue Jan 13 00:27:58 CET 2015

On Mon, Jan 12, 2015 at 06:06:34PM -0400, George N. White III wrote:
> > So I'm using linux. The distro is Sabotage-Linux
> > https://github.com/sabotage-linux/sabotage
> Not a good choice for non-experts.  Is there a reason you can't use a
> mainstream linux?  If we know more about what you wish to accomplish we
> might be able to provide useful advice.

No, I can use a mainstream distribution. But sabotage is the one I prefer.
And I had no problem I can't deal before.

> > The perl version
> > is perl 5, version 16, subversion 3
> > The installer version is: 20150110
> >
> > The shell is ash from busybox. I have write permission on /usr/local
> >
> You mentioned that you installed as "root".  That is generally not a good
> idea.  A better
> approach is to create the toplevel directory, e.g.. /usr/local/texlive, and
> change the
> ownership to an ordinary user who will administer texlive.

I was doing this before, I did it with a normal user, and the same error.

> It is quite possible that ash isn't totally compatible with the texlive
> scripts.  Can you install
> dash or bash for testing?
This is something I suspect, I will try with bash.

> > Now I tried to set the path before the installation and didn't worked.
> The installer should use the appropriate path when running kpathsea

With path here I mean the enviroment variable PATH of the binaries. I suspected
the problem was that texlive was trying to execute a file from the new 

> Show us "ls -l ./tex" and "ldd tex", assuming you have or can install
> "ldd".

~/texlive/2014/bin/x86_64-linux $ ls -l ./tex
-rwxr-xr-x    1 henrique wheel       374416 Apr 28  2014 ./tex

~/texlive/2014/bin/x86_64-linux $ ldd tex
/lib64/ld-linux-x86-64.so.2 (0x7f68b3682000)
libm.so.6 => /lib64/ld-linux-x86-64.so.2 (0x7f68b3682000)
libc.so.6 => /lib64/ld-linux-x86-64.so.2 (0x7f68b3682000)
So now you talked about a interesting thing. You made me see that the tex binaries are
dynamic linked. Here, I don't have glibc, I use musl (the other libraries are normal).
So would this be the problem?


Henrique Lengler

More information about the tex-live mailing list