[tex-live] Errors in installation via install-tl

George N. White III gnwiii at gmail.com
Mon Jan 12 23:06:34 CET 2015

On Mon, Jan 12, 2015 at 4:12 PM, Henrique Lengler <henriqueleng at opmbx.org>

> On Mon, Jan 12, 2015 at 03:49:35PM +0000, Lars Madsen wrote:
> > Might be a good idea to mention what kind of system you are on.
> >
> > Which version of the installer did you use (when you download and unpack
> it, the created folder has a date in the name.
> So I'm using linux. The distro is Sabotage-Linux
> https://github.com/sabotage-linux/sabotage

Not a good choice for non-experts.  Is there a reason you can't use a
mainstream linux?  If we know more about what you wish to accomplish we
might be able to provide useful advice.

> The perl version
> is perl 5, version 16, subversion 3
> The installer version is: 20150110
> The shell is ash from busybox. I have write permission on /usr/local

You mentioned that you installed as "root".  That is generally not a good
idea.  A better
approach is to create the toplevel directory, e.g.. /usr/local/texlive, and
change the
ownership to an ordinary user who will administer texlive.

It is quite possible that ash isn't totally compatible with the texlive
scripts.  Can you install
dash or bash for testing?

> Now I tried to set the path before the installation and didn't worked.

The installer should use the appropriate path when running kpathsea

I also tried to install in my home folder and I got the same errors.
> If I cd into the directory and try to run some of the bins, I get:
> $ cd texlive/2014/bin/x86_64-linux/
> ~/texlive/2014/bin/x86_64-linux $ ls
> afm2tfm           dvips             gsftopk           kpsexpand
>  mkofm             rungs             texluajit
> allcm             dvired            inimf             luajittex
>  mktexfmt          simpdftex         texluajitc
> allec             ebb               initex            luatex
> mktexlsr          tex               tlmgr
> allneeded         etex              kpseaccess        makeindex
>  mktexmf           texconfig         updmap
> bibtex            extractbb         kpsepath          man
>  mktexpk           texconfig-dialog  updmap-sys
> dvi2fax           fmtutil           kpsereadlink      mf
> mktextfm          texconfig-sys     xdvi
> dviluatex         fmtutil-sys       kpsestat          mf-nowin
> pdfetex           texhash           xdvi-xaw
> dvipdfm           gftodvi           kpsetool          mft
>  pdftex            texlinks
> dvipdfmx          gftopk            kpsewhere         mkindex
>  pktogf            texlua
> dvipdft           gftype            kpsewhich         mkocp
>  pktype            texluac
> ~/texlive/2014/bin/x86_64-linux $ ./tex
> /bin/sh: ./tex: not found
Show us "ls -l ./tex" and "ldd tex", assuming you have or can install

> Regards,
> Henrique Lengler

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20150112/7b845ae1/attachment.html>

More information about the tex-live mailing list