[tex-live] strange changing permissions

Victor Ivrii vivrii at gmail.com
Thu Mar 18 12:38:55 CET 2010

On one of computers I run texlive maintenance not as a root but as a
special user "texlive" and I noticed that if tlmgr runs

running updmap-sys ...
done running updmap-sys.

then ordinary users are getting errors

% pdflatex TT2010SA.tex
/usr/local/texlive/2009/texmf/web2c/texmf.cnf: Permission denied
This is pdfTeX, Version 3.1415926-1.40.10 (TeX Live 2009)

kpathsea: Running mktexfmt pdflatex.fmt
/usr/local/texlive/2009/texmf/web2c/texmf.cnf: Permission denied
/usr/local/texlive/2009/bin/x86_64-linux/mktexfmt: line 362:
/texconfig/tcfmgr: No such file or directory
fmtutil: config file `fmtutil.cnf' not found.
I can't find the format file `pdflatex.fmt'!

If I as "texlive" change reading permissions it goes back to normal.
If "texlive" runs updmap-sys then no such behavior. Also on comuters
where I run tlmgr as a root such behavior is not observed

umask of all directories there is 77

It is a bit of annoyance to remember to change permissions


Victor Ivrii, Professor, Department of Mathematics, University of Toronto

More information about the tex-live mailing list