[tex-live] epstopdf Issue

Justin Holewinski shawmishrak at gmail.com
Thu Aug 20 20:01:40 CEST 2009

Hi All,

I am having an issue with the epstopdf tool, on TexLive 2008 on both Mac OS
X and Windows.  If I use GraphViz to generate a postscript file, epstopdf
will fail to convert it to a PDF file with a Ghostscript stack trace, as

acheron:graphviz jholewinski$ epstopdf graph.eps
Error: /undefined in or:
Operand stack:

Execution stack:
   %interp_exit   .runexec2   --nostringval--   --nostringval--
--nostringval--   2   %stopped_push   --nostringval--   --nostringval--
--nostringval--   false   1   %stopped_push   1905   1   3   %oparray_pop
1904   1   3   %oparray_pop   1888   1   3   %oparray_pop   1771   1   3
%oparray_pop   --nostringval--   %errorexec_pop   .runexec2
--nostringval--   --nostringval--   --nostringval--   2   %stopped_push
Dictionary stack:
   --dict:1152/1684(ro)(G)--   --dict:0/20(G)--   --dict:70/200(L)--
Current allocation mode is local
Last OS error: 2
GPL Ghostscript 8.63: Unrecoverable error, exit code 1

However, the conversion works if I manually invoke Ghostscript with
epstopdf's output (Ghostscript command-line options obtained using `epstopdf
--debug` output):

acheron:graphviz jholewinski$ epstopdf --outfile=graph.tmp --nogs graph.eps
&& cat graph.tmp | gs -q -sDEVICE=pdfwrite  -dPDFSETTINGS=/prepress
-dMaxSubsetPct=100 -dSubsetFonts=true -dEmbedAllFonts=true
-dAutoRotatePages=/None  -sOutputFile="graph.pdf" - -c quit

Does anyone know what causes this, or what the solution is?  The graphs in
question are being generated and converted by Doxygen, so I have no control
over how epstopdf is being invoked and cannot simply use this two step
process.  I read of some related issues related to line endings, but
changing the line endings to CR, LR, or CRLF does not help in this case.
The issue is also not specific to Doxygen.  The same error occurs with a
simple GraphViz graph:

digraph G
  V1 -> V2;

acheron:graphviz jholewinski$ dot -Tps graph.dot -o graph.eps
acheron:graphviz jholewinski$ epstopdf graph.eps
Error: /undefined in or:
Operand stack:

I have tried TexLive 2007 on Linux, and the problem does not seem to appear.



Justin Holewinski
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20090820/b413e997/attachment.html>

More information about the tex-live mailing list