not found [SUCCESS (really this time0]

Haines Brown haines at
Tue Dec 7 13:46:39 CET 2021

On Mon, Dec 06, 2021 at 03:07:50PM -0700, Karl Berry wrote:
> Hi Haines,
>       !pdfTeX error: pdflatex (file ptmr8r): Font ptmr8r at 600 not found
> These problems are all about the (pdftex) or
> (dvips) file. The underlying problem is what you noticed -- updmap.cfg
> containing only that one line. If you run kpsewhich --all updmap.cfg, it
> should show the different files being used, and the main one, presumably
> /usr/local/texlive/2021/texmf-dist/web2c/updmap.cfg
> should have hundreds of lines in it (one for each package providing
> fonts that need map files).
> When you "copied over the fonts", you bypassed package installation,
> which is what would update updmap.cfg. So it might work to "copy over"
> the above updmap.cfg to the new machine (and then run updmap-sys
> again).
> Or perhaps if you run updmap-sys --syncwithtrees it will find the
> missing map files and offer to update the updmap.cfg; I can't say I've
> ever really tried it, but the option is there.
> newtx vs. mathptmx is not the problem. You will get the same error with
> virtually any non-CM font. --hope this helps, karl.

I did copy over the old updmap.cfg and ran it. But using it produced 

  updmap [ERROR]: The following map file(s) couldn't be found:
  updmap [ERROR]: (in /usr/local/texlive/2021/texmf-config/web2c/updmap.cfg)

Running updmap-sys again did not help.  

I looked at the new updmap.cfg and found in it the line

  Map pxtx in updmap.cfg

So followed your advice and did 

   updmap-sys --syncwithtrees

That fixed the problem: pdflatex produces a PDF without error.  I thank

Apparently I made a mistake when setting up the new system by simply copying
font files over.  Are you implying I should not have done with fonts from the
old /usr/local/texlive/texmf-local/fonts? If not what would have been the 
proper procedure?

Haines Brown  

More information about the texhax mailing list.