[texhax] Mysterious hang-up using bibtex.

Rolf Turner r.turner at auckland.ac.nz
Sat Jun 29 02:11:20 CEST 2013

On 29/06/13 09:54, Karl Berry wrote:
>      But then (usually it seems) after a ***long*** while and repeated
>      re-attempts,
>      everything suddenly works!  I then get:
> If you haven't figured it out by now ...
> I suspect it's searching your whole filesystem, due to some sort of
> envvar missetting, of, say, BSTINPUTS.  You could run
>    env KPATHSEA_DEBUG=-1 bibtex demo >/tmp/out 2>&1
> And get voluminous debugging output.  What's in there should show the
> path that bibtex is using for BSTINPUTS and why it's doing what it's
> doing.
> Hope this helps,
> Karl
It *seems* to have helped!  I found that I indeed had a mixed up
setting of BSTINPUTS in my .cshrc file.  (For reasons that I won't try
to explain I use tcsh rather than bash.)  I had


in my BSTINPUTS before /usr/local/texlive//:

I *used* to have my texlive directory in own personal Texstuff directory.
Can't really remember why; probably because of a misunderstanding on
my part.

But anyway, even after I corrected my .cshrc and removed reference to
/home/rolf/Texstuff in BSTINPUTS the hang-up syndrome persisted.

Then I looked through the /tmp/out file that I created according to your
instructions.  I found several references to /home/rolf/.texlive.

I removed that hidden directory, rebooted and did the latex demo; bibtex 
routine again.

The first time I did it the "latex demo" part took a very long time; several
minutes.  I was in fear and trembling, but waited patiently and eventually
it ran/completed.  Then the bibtex command ran immediately, no hang-up.

I rebooted again and tried again.  Again the latex command took forever
to run (the first time) but then ran promptly on succeeding tries. And again
bibtex did not hang.

So my problem appears to be solved.  But at the expense of introducing a new
(although relatively minor) problem in that the first time latex is 
invoked after a
reboot the command takes several minutes to complete.  I don't really 
why my original problem was solved, or what is inducing the new problem.
What was that .texlive directory doing?  Where did it come from? Was
that *really* what was causing the problem.

These things are such a mystery to me!

But as I say, my original problem seems to have been solved, so thanks!



More information about the texhax mailing list