[texhax] Font installation

Lars Madsen daleif at imf.au.dk
Wed Aug 14 17:04:50 CEST 2013

exactly where are those map files? Is it in the appropriate TDS structure?

I usually do a

kpsewhich file.map

to verify that it is found before I run updmap-sys

/Lars Madsen
Institut for Matematik / Department of Mathematics
Aarhus Universitet / Aarhus University
Mere info: http://au.dk/daleif@imf / More information: http://au.dk/en/daleif@imf

From: texhax [texhax-bounces at tug.org] on behalf of Henrik Frisk [frisk.h at gmail.com]
Sent: 14 August 2013 16:50
To: texhax at tug.org Hax
Subject: Re: [texhax] Font installation

Dear all,

I have not yet been able to resolve this issue. I'm trying to install two adobe fonts that I have used with TeX before (AGaramond and Frutiger). This time it is not working at all. I have put all the font files in my TEXMFLOCAL directory but I can't add the map files. The output of updmap-sys is:

$ updmap-sys --enable Map=agaramond.map
[sudo] password for henrikfr:
updmap is using the following updmap.cfg files (in precedence order):
updmap is using the following updmap.cfg file for writing changes:
/usr/local/texlive/2012/texmf-config/web2c/updmap.cfg unchanged.  Map files not recreated.
updmap: Updating ls-R files.

As you can see the texmf-local directory is not included here which makes me think there is something wrong with the environment variables. This is what I have currently:

$ kpsewhich --var-value TEXMFLOCAL
$ kpsewhich --var-value TEXMFHOME
]$ kpsewhich --var-value TEXMFVAR

Any suggestions?


On Sun, Mar 3, 2013 at 8:05 PM, Herbert Schulz <herbs at wideopenwest.com<mailto:herbs at wideopenwest.com>> wrote:

On Mar 3, 2013, at 12:34 PM, Henrik Frisk <frisk.h at gmail.com<mailto:frisk.h at gmail.com>> wrote:

>> For the record, the very first release of TeX Live was based on teTeX
>> and thus supported Unix systems only.  The second release already
>> supported Windows too, providing the Windows binaries from fpTeX,
>> compiled by Fabrice.
>> Ulrike,
>> updmap is as old as teTeX.  The first version did not have the
>> --enable option and users had to edit the config file manually.
>> A later version introduced the --enable option, but this happened
>> more than a decade ago.  Unfortunately I currently don't have anything
>> older than TeX Live 2003 installed, but I can at least confirm that
>> the commands described above were supported ten years ago already.
> Thanks Reinhard for that information.
> I have now upgraded to TeXlive2012 and tried to reinstall the files
> but with the same depressing result. Everything now lives in
> /usr/local/texlive/texmf-local. If it wasn't for the fact that I have
> used these fonts before I would think there is something not right
> with the files.
> However, I still think there's womething not right with the search
> path. Though kpsewhich --var-value TEXMFLOCAL gives me
> /usr/local/texlive/2012/../texmf-local running updmap-sys --enable
> Map=map does not list this file. mktexlsr does however. Any thoughts
> would be greatly appreciated!
> /H


What is the path to the font.map file as reported by kpsewhich: i.e., what does

kpsewhich font.map


What are you using for `map' in

updmap-sys --enable Map=map

command? Who owns your TeX distribution? If it's owned by root you need to use `sudo' before the command.

Finally, did you ever run updmap rather than updmaap-sys? If so you have a map file in your personal texmf-var (TEXMFVAR as opposed to TEXMFHOME) which is overriding the system one.

Good Luck,

Herb Schulz
(herbs at wideopenwest dot com)

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/texhax/attachments/20130814/81b758cc/attachment.html>

More information about the texhax mailing list