[texhax] includegraphics clipping failing, help?

Mike Kordosky makordosky at wm.edu
Fri Jul 18 05:35:09 CEST 2008


I'm wondering if someone can help me debug a problem, or just comiserate.

I have an eps figure, possibly converted from ps, which I cannot clip when
inserting into a tex document processed by latex.  I can modify the original
eps file to change the bounding box to my liking and it looks fine in gv.
But, when the figure is inserted via \includegraphics[clip=true]{myfig.eps}
the resulting ps document (also viewed with gv!) shows the entire thing.
However, I can see that the bounding box is there. For instance, if I
scrutinize the figure alignment. Also if I look at the dvi with xdvi I can
use its option to show the bounding box, and it looks right.  However, for
some reason the output of latex (both the dvi and the ps file produced by
dvips) do not *clip*. I've tried inserting explicit "bb= lx ly ux uy"  (and
"trim= ...") in the includegraphics but it doesn't help. I've played around
with the viewport and it I think does the usual thing (I don't use it much)
but still no clipping.  When printed the document has no clipping.  The PDF
from ps2pdf also has no clipping. I've tried various incantations of ps2epsi
and so on, but no luck.

I'm using the following programs. Any advice appreciated:

pdfTeX using libpoppler 3.141592-1.40.3-2.2 (Web2C 7.5.6)
kpathsea version 3.5.6
Copyright 2007 Peter Breitenlohner (eTeX)/Han The Thanh (pdfTeX).

gv 3.6.3

Mike Kordosky

kordosky at fnal.gov      // Department of Physics
makordosky at wm.edu // Coll. William and Mary
Small Hall 320A
Phone: +1 (757) 221 5522
FAX:    +1 (757) 221 3540
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://tug.org/pipermail/texhax/attachments/20080717/c8b25c50/attachment.html 

More information about the texhax mailing list