[texhax] Vista

Michael Barr barr at math.mcgill.ca
Mon Sep 3 18:47:07 CEST 2007

Has anyone gotten tex (and, especially mf) to run correctly under Vista?

As brief as I can make it, here is my experience.  I accepted a full 
installation from the TeXLive 2007 CD (or DVD, I didn't pay attention).  
It seemed to install properly and I got tex working with no problem (I had 
to install xypic and my own diagxy).  When I tired to run the viewer, I 
got mysterious error messages I wrote about previously.  I tried to use a 
suggestion from Reinhard Kotucha to use pdftex.  Instead I tried dvipdfm, 
but I don't think there is any essential difference.  Here is the error 
message I got:

[c:\math\tac]dvipdfm isbell1

isbell1.dvi -> isbell1.pdf
[1kpathsea: Running mktexpk --mfmode / --bdpi 600 --mag 1+0/600 --dpi 600 
mktexmf: empty or non-existent rootfile!
mktexpk: don't know how to create bitmap font for xyatip10.kpathsea: 
Appending f
ont creation commands to missfont.log.
xyatip10: Can't locate a Type 1, TTF, PK, or virtual font file

Not sure how to proceed.  For now this is fatal
Maybe in the future, I'll substitute some other font.

Output file removed.

I gave up and copied the entire miktex directory from my old computer 
(there were nearly 600 MB and it took 22 minutes) and tried running it.  
When I ran yap, I got a mysterious message about a missing font. Well, the 
font is there and it is where mf put it running under yap on my old 
computer.  The display seemed to be correct except for missing characters 
from the Zapf chancery fonts, which are in the location
and yap was unable to make them either.  There is an error message from 
yap located somewhere, but well hidden unless you know exactly where to 

Incidentally, AFAIK, TeX works fine; it is only the fonts that are a 
problem.  Since I had copied the directory in toto, it didn't seem 
necessary to run mktexlsr, but I did anyway after the first failure.  My 
old computer has no relevant environment variables (except the path) set 
so that cannot be the problem.

My best guess is that some permissions are not allowed, although that does 
not explain yap's failure to find just one font.

Michael Barr

More information about the texhax mailing list