[texhax] redefinition of \= does not get into footnotes

Alexandru Scorpan ascorpan at math.ufl.edu
Fri Sep 10 12:41:04 CEST 2004

>> The point of my maneuver was to add some extra space around =, so I 
>> tried \renewcommand*\@aciii{\mathbin{\,=\,}} instead, but got 
>> ``missing $ inserted''.  Tried your version, same error.
> You didn't say you were going to use it outside math mode... Just put 
> an \ensuremath around \mathbin{\,=\,}.

No, I am not using it outside math.

Here a sample file, that yields ``missing $ inserted'' when it 
encounters the math display with \=:

\[ A\= B \]

The funny thing is that just adding the @-code after \begin{document} 
yields the error ``\@aciii undefined''.

>> I guess I should stick to my crappy hack, going wth
>> \let\footnoteclone\footnote
>> \renewcommand{\footnote}[1]{%
>> 	\footnoteclone{\renewcommand\={\mathbin{\,=\,}}#1}}
> Nooooo! This is the wrong place to hack anyway.

But works fine on my 600-page document.


More information about the texhax mailing list