[tlu] TeX Live Utility (MacTeX) critical update failure

Bruno Voisin bvoisin at icloud.com
Fri Nov 17 01:14:29 CET 2023

> On 16 Nov 2023, at 22:47, Karl Berry <karl at freefriends.org> wrote:
>    ./runme.sh: no xz.[universal-darwin][.exe] binary for 
>    /usr/local/texlive/2023/bin/universal-darwin in 
>    /var/folders/c9/mqg453cx4bg50wwbqxsr4x0w0000gn/T/selfgz3210124610/installer/xz.
> 2) It's unclear to me why the xz executable is not there for TLU, since
> it is there in the repo's .../installer/xz directory:
> $ ls -l tlpkg/installer/xz/xz.universal-darwin
> -rwxrwxr-x. 1 karl root 451744 Mar  2  2022 tlpkg/installer/xz/xz.universal-darwin*
> Also, the self-update worked on (all?) other platforms.

This seems specific to TLU.

I had the exact same problem earlier today with TLU (macOS 14.2 beta 3, MacTeX 2023), with the same error message. I thought the problem was with update-tlmgr-latest.sh (ie that somehow it was supposed to include xz.universal-darwin but didn't). I didn't report and waited for others to diagnose and fix.

Right now, motivated by Karl's message, I tried again this time with tlshell (having compiled tcl/tk 8.6.13 beforehand, macOS includes tcl/tk 8.5 which doesn't work with tlshell).

So I pressed the "Update tlmgr" button, and all went well. After that, TLU doesn't mention there's a TeX Live infrastructure update to apply, and just offers a list of standard updates to apply.

Maybe the above doesn't make sense. I wrote it assuming that all of the following

- Update the TeX Live infrastructure [TLU]

- Select Actions > Reinstall TeX Live Manager [TLU]

- Click the "Update tlmgr" button [tlshell]

- sudo tlmgr update --self [Terminal]

are equivalent. Maybe they don't. If so, sorry for the noise.

Bruno Voisin

More information about the tex-live mailing list.