error with lualatex but not with xelatex

Ken Moffat zarniwhoop at
Sun Jul 30 21:19:41 CEST 2023

On Fri, Jul 28, 2023 at 02:58:27AM +0100, Ken Moffat via tex-live wrote:
> On Thu, Jul 27, 2023 at 04:01:07PM +0200, Ulrike Fischer wrote:
> > Am Thu, 27 Jul 2023 06:17:04 +0100 schrieb Ken Moffat via tex-live:
> > 
> > > This is texlive-2023 with patches to update LuaTeX to 1.17.0,
> > 
> > Well then you should perhaps at first try if you get the same error
> > with a native texlive (which has luatex 1.17.0 too). 
> > 
> I hope to do that eventually, but at the moment I lack a suitable
> spare system.

Found temporary space on a fresh build, installed current full
binary (might have other changes apart from moving to
lualatex-1.17.0), that worked.

Came back to this problem system, still fails with UnDotum (system
font), but if I use Noto Sans CJK KR or Baekmuk Dotum (both as
system fonts) it works fine with lualatex.

Back when I was using TL2015 I discovered that lualatex could not
find the Sawarabi Mincho japanese font (swarabi-mincho-medium.ttf),
but xelatex had no problem with it, so I commented that font out of
my script where it looks for japanese fonts.  I suspect this is
something similar, and I have no bandwidth to try to work out what
is going wrong - in any case I doubt I have the necessary skills or

In the unlikely event that anybody cares, the ABOUT tarball I
attached does not contain the required VERSION and triskel.pdf
files.  Ask me if you want those to look at this.

    That just goes to show that you never know, although what
    it is we never know I suspect we'll never know. -- Snuff

More information about the tex-live mailing list.