Loss of some glyphs in Droid Sans Fallback font

Ken Moffat zarniwhoop at ntlworld.com
Sat Jul 15 19:36:22 CEST 2023

I'm periodically revising some of my own test scripts and the
documentation for them.  One of the things I do is use various OTF
or TTF fonts to cover Article 1 of the Declaration of Human Rights.

Originally (about 9 years ago) I used xelatex, but I decided a few
weeks ago that lualatex is what I want to use for this.  Made some
initial changes to get more on the page, left it as W-I-P so did not
pay too much attention to those examples.  Today I tried it again to
compare using lualatex and xelatex.  Noticed a lot of hyperref
messages (not a problem) but scrolled back, and found that 4 of the
cantonese glyphs were not in Droid Sans Fallback.  That is true
whether I use lualatex or xelatex, if I look at the pdf with mupdf I
can see the empty boxes.  This is using system fonts rather than
fonts from texlive.

The odd thing is that I'm still using the Droid-Sans-Fallback.zip
file which I downloaded from somewhere in 2014 that contains
DroidSansFallback.ttf dated 2008-10-22.

I changed to WenQuanYi Zen Hei which is what I use in terminals
(xfce4-terminal) and which shows the glyphs, and in lualatex that
works fine.  So, I have worked around this and am happy to use the
WenQuanYi font, but puzzled about what broke this.

Looking in Gnome Character Map I see that does not find the glyphs,
e.g. U+5605, so I suspect it is not a texlive bug, but I'd
appreciate any comments from people using recent linux or BSD
systems who do have DroidSansFallBachk.ttf.

My version of fontconfig on this system is 2.14.2 and I'm using


\setmainfont{DejaVu Sans}


\subsection{Cantonese \textit{using Droid Sans Fallback}}
{\fontspec{Droid Sans Fallback}
人人生出嚟就係自由嘅,喺尊嚴同權利上一律平等。佢哋具有理性同良心, \\
而且應該用兄弟間嘅關係嚟互相對待。 \\

\subsection{Cantonese \textit{using WenQuanYi Zen Hei}}
{\fontspec{WenQuanYi Zen Hei}
人人生出嚟就係自由嘅,喺尊嚴同權利上一律平等。佢哋具有理性同良心, \\
而且應該用兄弟間嘅關係嚟互相對待。 \\


Attaching the PDF so peopel can see my results.


You can't always get what you want
But if you try sometimes, you just might find
You just might find, you get what you need.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: mwe-cantonese.pdf
Type: application/pdf
Size: 93267 bytes
Desc: not available
URL: <https://tug.org/pipermail/tex-live/attachments/20230715/e446f7f8/attachment-0001.pdf>

More information about the tex-live mailing list.