"tlmgr" on "Ubuntu 22.04"

peacecop kalmer: kalmer at test.tennis24.ee
Fri Jul 29 01:45:10 CEST 2022

 1. If i /export/ /PATH/ it's valid for the current session and
    rebooting cancels it unless it's permanently stored in /.profile/.
 2. peacecop at peacecop-HP-ProBook-4520s:~$ type -ap tlmgr
    peacecop at peacecop-HP-ProBook-4520s:~$ type -ap tex
 3. peacecop at peacecop-HP-ProBook-4520s:~$ ls -l
    /usr/local/texlive/2022/bin/x86_64-linux | grep 'tlmgr'
    lrwxrwxrwx 1 root root       41 okt    4 2018 tlmgr ->
 4. peacecop at peacecop-HP-ProBook-4520s:~$ mkdir -p ~/.config/environment.d/
    peacecop at peacecop-HP-ProBook-4520s:~$ echo
    'PATH=/usr/local/texlive/2022/bin/x86_64-linux/:${PATH}' >
    After reboot, /TeXstudio/ works like before and no /sudo/ is needed.
    Even /tex-locale/ is found. However, /tlmgr/ still acts weird:
    peacecop at peacecop-HP-ProBook-4520s:~$ tlmgr install tex-locale
    You don't have permission to change the installation in any way,
    specifically, the directory /usr/local/texlive/2022/tlpkg/ is not
    Please run this program as administrator, or contact your local admin.
    tlmgr: An error has occurred. See above messages. Exiting.
    peacecop at peacecop-HP-ProBook-4520s:~$ sudo tlmgr install tex-locale
    [sudo] password for peacecop:
    sudo: tlmgr: command not found
    peacecop at peacecop-HP-ProBook-4520s:~$ which tlmgr
    If i do just /tlmgr list/ then i get the list.
 5. /bash/
 6. peacecop at peacecop-HP-ProBook-4520s:~$ env | grep -i tex
    peacecop at peacecop-HP-ProBook-4520s:~$ sudo env | grep -i tex
    no output
 7. Done that, no change.

On 29.07.22 01:58, Max Chernoff wrote:
>> You probably missed the part of my report that had it in already:
> Yep, I completely missed that. Whoops.
>> As you see, i the /2022/ version was installed, /PATH/ was renewed and
>> still, it complains that the version is /2021/.
>> Your suggested command does the same thing.
> I'm not too sure what's going on here, but I have a couple of potential
> ideas:
> 1. Have you tried rebooting since you installed TL? Sometimes the
> profile file is only source'd on login, so this may solve the problem.
> 2. What do you get when you run:
>     type -ap tlmgr
>     type -ap tex
> On my system, I get:
>     $ type -ap tlmgr
>     /usr/local/texlive/2022/bin/x86_64-linux/tlmgr
>     $ type -ap tex
>     /usr/local/texlive/2022/bin/x86_64-linux/tex
> If you aren't getting TL 2022 as the first result for both commands
> (which I strongly suspect is the case), that means that you're going to
> have problems (which you are).
> 3. There's a chance that there's a weird permission thing going on here.
> What do you get when you run:
>     ls -l /usr/local/texlive/2022/bin/x86_64-linux | grep 'tlmgr'
> I get:
>     lrwxrwxrwx. 1 root root       41 Oct  3  2018 tlmgr -> ../../texmf-dist/scripts/texlive/tlmgr.pl
> 4. I've sometimes had better luck using systemd-environmentd to set
> environment variables. You can try running
>     mkdir -p ~/.config/environment.d/
>     echo 'PATH=/usr/local/texlive/2022/bin/x86_64-linux/:${PATH}' > ~/.config/environment.d/texlive-path.conf
> then reboot. Does this fix anything?
> 5. Are you using bash as your shell? If you're using Zsh, ksh, or csh,
> then there may be some special way of adding things to your path that
> I'm not aware of. I'm using fish, so I would need to run
> "fish_add_path".
> 6. You said that using sudo works. What do you get when you run:
>     env | grep -i tex
>     sudo env | grep -i tex
> I get:
>     $ env | grep -i tex
>     PATH=/opt/context/tex/texmf-linux-64/bin:/usr/local/texlive/2022/bin/x86_64-linux:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin
>     sudo env | grep -i tex
>     (no output)
> 7. You can try clearing the bash PATH cache by running:
>     hash -r
>> Should i run /TeXstudio/ as /sudo/ further on? Is that normal?
> Probably not a great idea.
> Anyways, this is all the ideas that I have. Hopefully someone else can
> be more helpful, since I'm doubtful that any of these solutions will
> work.
> -- Max
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://tug.org/pipermail/tex-live/attachments/20220729/8ccac899/attachment-0001.html>

More information about the tex-live mailing list.