kpathsea SELFAUTOLOC is wrong

Ben Smith bensmithmath at
Sat Sep 19 02:11:09 CEST 2020


echo $SELFAUTOLOC gives an empty line. There were no tex-related variables
defined when I ran env.

Vladimir, Here's the requested output:

[ben at tp4 ~]$ command -v pdflatex
[ben at tp4 ~]$ command -v kpsewhich
[ben at tp4 ~]$ which pdflatex
[ben at tp4 ~]$ which kpsewhich
[ben at tp4 ~]$ whereis pdflatex
pdflatex: /usr/bin/pdflatex
[ben at tp4 ~]$ whereis kpsewhich
kpsewhich: /usr/bin/kpsewhich
[ben at tp4 ~]$ env | grep -i tex

So I think your hunch is right! I have the arch texlive-bin package
installed in addition to the version. I just looked it up with
`pacman -Qi texlive-bin`, and it came as a dependency of xournalpp which I
installed before the version. Now, I just ran:

$ /usr/local/texlive/2020/bin/x86_64-linux/latex small2e

and it looks like it worked. Then, I changed my PATH-setting command to:


So that the previous $PATH is at the back instead of the front... and then
running just:

$latex small2e

worked just fine! I'm not sure if i should uninstall the texlive-bin
package or not. I don't want to break xournalpp which I use for work every

Ben Smith

On Fri, Sep 18, 2020 at 4:39 PM Vladimir Lomov <lomov.vl at> wrote:

> Hello,
> ** Ben Smith <bensmithmath at> [2020-09-18 14:31:42 -0700]:
> > Hi, I installed texlive 2020 last week on my thinkpad x1 yoga (gen 4)
> > last week, running arch linux. I used the download script from
> > It successfully installed, but is not working. kpathsea seems
> > to be looking for files in the wrong place, and can't find texmf.cnf
> > or latex.fmt or anything. After some digging around I found that
> > SELFAUTOLOC is set to /usr/bin, but my whole texlive is installed in
> > /usr/local/texlive. (I get this by running kpsewhich
> > -var-value=SELFAUTOLOC)
> Please provide more details.
> Show output of (I assume that your shell is bash or zsh):
> $ command -v pdflatex
> $ command -v kpsewhich
> $ which pdflatex
> $ which kpsewhich
> $ whereis pdflatex
> $ whereis kpsewhich
> $ env | grep -i tex
> > On my older computer with texlive working, with everything installed
> > in the same directories, SELFAUTOLOC is
> > /usr/local/texlive/2020/bin/x86_64-linux. This computer is also
> > running arch linux, and I installed texlive from the script
> > three months ago.
> > It also seems like SELFAUTOPARENT and SELFAUTOGRANDPARENT are wrong.
> > texmf.cnf says that these variables are generated in
> > kpathsea/progname.c but I don't seem to have that file to check.
> I'm Archlinux user too and use TeX Live from TUG as well as has texlive*
> packages installed by pacman (Archlinux package manager).
> > Thanks!
> > Ben Smith
> > PS I tried to report a bug following the instructions at
> > but the
> > address tex-k at was not found.
> That is pitty but I doubt that the problem is with kpathsea.
> ---
> WBR, Vladimir Lomov
> --
> Toothpaste never hurts the taste of good scotch.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the tex-live mailing list.