Use of uninitialized value $r in split at /usr/share/texlive/tlpkg/TeXLive/ line 4157.

Maria Matveev maria at
Thu Feb 20 07:47:49 CET 2020

Dear TeX-Live-Team,

I tried to use tlmgr to install a missing package, namely extarrows, as 

Since I got an error, I tried to resolve it as in

Cannot determine type of tlpdb from /home/maria/texmf!
cannot setup TLPDB in /home/maria/texmf at /usr/bin/tlmgr line 6424.

Trying to solve this, I got an error message, which I as asked report to 
you now.

You can see all my actions in the screenshot attached.

I am running on an Ubuntu 18.04, and I think that I installed 
texlive-base system-wide, but I am not 100% sure about that.

Best regards


Error Message:

sudo /usr/bin/tlmgr install extarrows
(running on Debian, switching to user mode!)
/usr/bin/tlmgr: Initialization failed (in setup_unix_one):
/usr/bin/tlmgr: could not find a usable xzdec.
/usr/bin/tlmgr: Please install xzdec and try again.
tlmgr: Couldn't set up the necessary programs.
Installation of packages is not supported.
Please report to texlive at
Use of uninitialized value $r in split at 
/usr/share/texlive/tlpkg/TeXLive/ line 4157.
tlmgr: Cannot find main repository, you have to tag one as main!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: maria_bug.png
Type: image/png
Size: 143986 bytes
Desc: not available
URL: <>

More information about the tex-live mailing list.