tlmgr: temporary directories not cleaned up

Johannes Hielscher jhielscher at
Thu Mar 7 13:03:04 CET 2019

Hi Norbert,

the mystery remains, but we are getting closer. On tuesday, I did
another two installations of TL19 pretest, on Debian stable and
FreeBSD, and waited until now for packages to be updated.

When nothing is to be done, the temporary directories are deleted just
after tlmgr finishes.

Today, there were package updates AND a new texlive.infra (50211 ->
50251), and on both new platforms, the folders in question remained…

# Debian
drwx------ 5 name group 4.0K Mar  7 12:00 /tmp/user/$UID/Ooo7GNPvoU/
# FreeBSD, $TEMP not set
drwx------ 5 name group  512 Mar  7 12:27 /tmp/Uptddrbh1_

containing a few empty folders, texlive.tlpdb, and the checksum of

On the third box, I ran --self and --all separately, and temporaries
were deleted properly.
But temporary files are always left over whenever tlmgr is invoked with
`--self --all` AND an texlive.infra update is installed.
I can reproduce this behaviour on all three boxes, either when package
updates come in, or with a rollback (`tlmgr restore --all` or `tlmgr
restore texlive.infra 50211`) from the now well-working backups.

My best explanation for this: at the moment where tlmgr is automatically
restarted after texlive.infra updates, it forgets to tidy up its
temporary folders.

BTW: I found such a directory dated May 2018 (for TL18-release updates;
I can't say any more if this has been a regular update or tlmgr just
crashed back then), so maybe this issue is not new to TL2019.


Am Wed, 6 Mar 2019 11:00:33 +0900
schrieb Norbert Preining <preining at>:

> Hi Johannes,
> On Tue, 05 Mar 2019, Johannes Hielscher wrote:
> > Some behaviour of tlmgr puzzles me. In my temporary directory
> > (TEMP=/tmp/user/$UID under Debian), each run of `tlmgr update --self
> > --all` (nothing else tried yet) creates a directory named with ten
> > random characters (upper-/lowercase, and underscores), that contains
> > files and subdirectories of equally obfuscated names. Each folder
> > takes  
> Strange, I cannot reproduce this:
> $ export TEMP=/tmp/foobar
> $ echo $TEMP
> /tmp/foobar
> $ ls $TEMP
> $ tlmgr update --self --all
> tlmgr (TLPDB): pinning warning: the package pattern texlive.infra* on
> the line: tlcritical:texlive.infra*
>   does not match any package
> tlmgr: package repositories
> 	main = /home/norbert/public_html/tlpretest (verified)
> 	tlcontrib
> = /home/norbert/Domains/server/ (verified)
> tltexjp = /home/norbert/public_html/tltexjp (verified) tlmgr: saving
> backups to /home/norbert/tl/2019/tlpkg/backups [1/1, ??:??/??:??]
> update: 12many [376k] (1587 -> 15878 at main) ... done running
> mktexlsr ... done running mktexlsr.
> running mtxrun --generate ...
> done running mtxrun --generate.
> tlmgr: package log
> updated: /home/norbert/tl/2019/texmf-var/web2c/tlmgr.log $ ls $TEMP
> $
> ?? Very strange?! I also checked other places temp files could be
> created, but nothing remains there. This is all on Debian/unstable but
> this shouldn't matter.
> Best
> Norbert
> --
> PREINING Norbert
> Accelia Inc.     +    JAIST     +    TeX
> Live     +    Debian Developer GPG: 0x860CDC13   fp: F7D8 A928 26E3
> 16A1 9FA0 ACF0 6CAC A448 860C DC13

More information about the tex-live mailing list