[tex-live] Asymptote 3D and gcc-6.1 ?

Ken Moffat zarniwhoop at ntlworld.com
Fri Jun 17 02:04:19 CEST 2016

Verging on O/T, but I'm not sure where to ask (I suspect the problem
is in freeglut) and I'm making no headway trying to debug this.

The linux x86_64 2016 binary works fine on my Beyond
Linuxfromscratch 7.9 system, where gcc is 5.3.1.  But on a
development system using gcc-6.1 it fails to create 3D drawings and
I can't get close to identifying the exact problem (the 2D drawings
seem fine).

The binary uses ncurses5, readline5, and freeglut from the host, but
since the 2D drawing is fine I am guessing that freeglut is the

I updated my test scripts to include a 3D drawing:
(run ./configure - it won't install anything - and then make
cylinder) but that juist craps out with:


LaTeX Warning: File `cylinder-1+0_0.pdf' not found on input line 14.

! Package pdftex.def Error: File `cylinder-1+0_0.pdf' not found.

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.
l.14 ...-1+0_0.pdf}}}{\ASYprefix\jobname-1+0.prc}}

and sure enough, all I have is cylinder-1.0.{pdf,prc} as well as
cylinder-1.{asy,pre,tex} : I tried diffing the stdout from runs on
gcc-5.3.1 and gcc-6.1 but it was too different for me to make any
sense of it.

Then I tried building asymptote from source on gcc-6.1, but of course
nothing changed (I did add extra deps such as fftw and Imaging).

I've tried kicking freeglut's cmake until I managed to get it to
build with no optimization at all (other gcc-6.1 bugs have sometimes
been worked around by disabling optimization), and then adding all
the -fno-this-and-that flags I've had to add to other packages, but
no change.

Can anybody offer any pointers, please ?

                       War is Peace
                    Freedom is Slavery
                   Ignorance is Strength

More information about the tex-live mailing list