[tex-live] Class scrartcl Error: undefined old font command '\it' and '\rm'

Michael Berger idest at online.de
Sat Jul 2 11:33:08 CEST 2016

On 07/02/2016 12:19 AM, Reinhard Kotucha wrote:
> On 2016-07-01 at 17:41:33 +0200, Uwe Siart wrote:
>   > Michael Berger <idest at online.de> writes:
>   >
>   > > This error turned up AFTER I started using the laTest availabe
>   > > TL2016, I never ever typed \is and/or \rm.  And I never saw this
>   > > error when using TL2013 with LyX 2.1.
>   >
>   > I'm not a LyX user/expert at all, but my rough guess is that LyX
>   > creates/uses those commands and scrartcl.cls stomached them in
>   > earlier versions but issues an error now.
> This is exactly what I assume too.  However, at a first glance it
> seems that LyX is the culprit because it creates the LaTeX code.  But
> it's also possible and certainly more likely that these deprecated
> commands are inherited from another macro package.
> The LaTeX team declared the old commands as being deprecated.  But in
> order to support old (LaTeX 2.09) documents too, they were kept.  If
> they aren't disabled (\let\rm\undefined), they are definitely allowed,
> though deprecated.
> What, on earth, is the variable
>    enabledeprecatedfontcommands
> good for?
Reinhard, it is a recommended workaround provided in the log file. This 
is ridiculous because itself is an already deprecated option!
I tried it on some of my LyX documents (as a document class option) and 
it worked, but failed on others.
If it works the log file is full with Warnings ... 'one should NOT use 
it because it is a deprecated option'! :-D

Thanks and cheers!

More information about the tex-live mailing list