[tex-live] strange output from "tlmgr install --all"

jack tljack at forallx.net
Wed Dec 21 16:07:06 CET 2016

>> tlmgr: cslatex mentioned, but neither new nor forcibly removed
> Can you try:
> 	tlmgr install cslatex
> and after that, depending on *what* you have installed, you can maybe do
> 	tlmgr remove cslatex
> (but I guess tlmgr will tell you that it is required by some other
> package).
> Norbert

I tried "tlmgr install clslatex", and it errored out while doing the
fmtutil-sys stuff.  Among the things I see are:

***** WARNING ******** CSLaTeX is obsolete, don't use it please *****
***** You can use ``normal'' LaTeX+Babel or XeLaTeX+polyglossia *****

Well then I *really* wish tlmgr would stop telling me things about
cslatex when I install unrelated things!

Loading english hyphenation patterns and exceptions
! OOPS!! Hyphenation patterns file czhyphen.tex for czech not found!.
\reserved at a ... at gobble \string \czech  not found!}

l.131 ...                        \@requesthyphens}
! Emergency stop.

And more errors that look similar to that.  When I tried "tlmgr remove
cslatex", I get:

tlmgr: not removing cslatex, needed by latex-bin
tlmgr: not removing cslatex.x86_64-darwin, needed by cslatex
tlmgr: no packages removed.

Is it within the last few days that latex-bin suddenly "needs" cslatex?
Can this be changed back?  Why would latex-bin "need" something that
tlmgr told me (above) is obsolete and should not be used?  Why would
latex-bin require it even if it *weren't* obsolete?   AFAIK I've been
getting by for around 8 or 9 years without having any hyphenation
patterns except English on my machine.

So I then tried "tlmgr remove --force cslatex", which did finally remove
cslatex.  But on the very next run of "tlmgr update --all", I see the
original message that this whole post is about: "cslatex mentioned, but
neither new nor forcibly removed".  Well, it *was* just forcibly
removed (and I wouldn't want to keep being told about forcibly removed
things anyway).

Perhaps somehow a tlpdb file acquired an erroneous line or two.
Inspection of texlive.tlpdb shows that it has "depend cslatex" in it.
Also, no other entries in my entire texlive.tlpdb mentions cslatex at
all in there.  I don't have polyglossia installed, and babel (which is
installed) doesn't mention cslatex.

Grepping for "cslatex" in $TEXLIVE/tlpkg reveals only two files that
mention it: texlive.tlpdb and latex-bin.tlpobj.  Each file contains two
occurrences of "cslatex", and if I delete all the occurrences, "tlmgr
update --all" will *still* spew the cslatex messages.


More information about the tex-live mailing list