[tex-live] gpg with tlmgr with tl 2016 pretest, etc, on a Mac

Jim Reeds jareeds at gmail.com
Thu Apr 28 01:04:18 CEST 2016

Dear Texlive:

I write to you because an error message invited me to.

I tried this on my MacBook Pro (2012) running El Capitan.

prompt$  tlmgr update -list

and got this

/Library/TeX/texbin/tlmgr: verification of checksum for
ftp://ftp.math.utah.edu/pub/texlive/tlpretest/ failed: cryptographic
signature verification of




failed. Output was

gpg: Signature made Tue Apr 26 21:29:26 2016 EDT using RSA key ID 19438C70

gpg: failed to create temporary file
Permission denied

gpg: Fatal: can't create lock for

Please report to texlive at tug.org

Then I tried

primpt$ sudo tlmgr update -list

and got this:



tlmgr: package repository ftp://ftp.math.utah.edu/pub/texlive/tlpretest/

tlmgr: saving backups to /usr/local/texlive/2016/tlpkg/backups

tlmgr: no updates available


( ls -ld /usr/local/texlive/2016/tlpkg/gpg/  shows

drwxr-xr-x  6 root  staff  204 Apr 27 18:40

so it is not surprising that sudo was needed.)

Is it right to require 'sudo' for such an operation?  All the above
commands are run from

an administrative account, but my day to day work is not.  As a day to day
non administrative

user I cannot use tlmgr this way?  But tlutil seems to work fine for the
non administrative

me, so I am really confused.

Thanks in advance, & with all best wishes
Jim Reeds
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20160427/496d3ba8/attachment-0001.html>

More information about the tex-live mailing list