[tex-live] documentation of TeX Live

jfbu jfbu at free.fr
Mon May 11 21:50:57 CEST 2015

Le 11 mai 2015 à 16:46, Herbert Schulz <herbs at wideopenwest.com> a écrit :

>> On May 11, 2015, at 9:29 AM, jfbu <jfbu at free.fr> wrote:
>> ...
>> XeTeX does not use this on Mac OS X, as far as I know, at least I
>> recall having followed the instructions some 3 to 5 years ago, got
>> bitten by it and moved forward to other things. Perhaps it changed
>> since?
> Howdy,
> On OS X you must make the TeX Live opentype fonts visible to the OS by either copying them into something like ~/Library/Fonts or creating a new Library (File->New Library (Opt-Cmd-N) in FontBook) that points to the opentype fonts folder in texmf-dist.
> I used to do the latter but with every minor OS update I had to re-do it so I gave up quite a while ago. Things may be better with more recent version of OS X; I don't know. I now do the former; simply copying that opentype folder to ~/Library/Fonts.

Hi Herb,

thanks for the info, I didn't know about "creating a new Library" 
in FontBook. And about copying fonts into ~/Library/Fonts I never
went through this step as it seemed a waste of disk space ...

> Note: under OS X if you reference the font by Font Name rather than File Name xetex uses the OS to find the file. However, if you reference the font by File Name it will find the font in the texmf-dist/fonts/opentype folder.

and if one uses filenames it seems in my (renewed) experience 

1) one must use ExternalLocation option to \setmainfont
2) bold, italic, bold-italic variants with corresponding filenames 
must be listed explicitely

> Yes, fontconfig is not used under OS X.

thanks for the confirmation. 

I am on 10.9.5 (mavericks). I experimented with your indications.

I will make a long story short because I spent two, no three, 
hours on this already.

1) I made the texmf-dist/fonts/opentype  repertory known to FontBook
as a "New Library" and it (sort of) worked

1a) I skip the details see however attached png about a problem
with Inconsolatazi-Bold

2) however FontBook would then take at least 2 or 3 minutes to

3) then I removed (manually) the created xml file
"TeX OpenType Fonts.library" from
$HOME/Library/FontCollections, launched and quit FontBook

4) then the test file using TeX Gyre Termes still worked !

5) after 45 minutes it stopped working. Ok, I figured, some cached
file finally was removed

6) I redo the steps, but only with TeX Gyre repertory, because
I had learned my lesson about not overloading FontBook

7) currently simple test file does *not* work anymore (but see
end of message)

> \documentclass{article}
> \usepackage{fontspec}
> \setmainfont{TeX Gyre Termes}
> \begin{document}
> Hello world.
> \textbf{Hello world.}
> \textit{Hello world.}
> \end{document}

Currently all TeX Gyre files do show perfectly well
in FontBook (quit relaunch, quit relaunch, ok)
but simple test file does not compile with any one.

I discovered during my testings that XCharter works
There is


which seems to help out fontspec.

  Extension = .otf ,
  BoldFont = XCharter-Bold,
  ItalicFont = XCharter-Italic,
  BoldItalicFont = XCharter-BoldItalic,
  UprightFont = XCharter-Roman,
  SmallCapsFeatures =  {Letters=SmallCaps}

Is this some hint that this could be the packaging of the
future for bundled TeXLive OpenType fonts and that they
would work out-of-the-box with XeTeX on Mac OS X ?

I have to report on another thing which happened, while
I first tried to make known the full texmf-dist/fonts/opentype
repertory to FontBook : 

--- This process found problems with Inconsolatazi4-Bold
--- (see attached png) and with the fonts whose names start
--- with  "Fandol"

I understand this not the appropriate mailing list to dwell on 
the user interface of Apple Mavericks Font Book but I just
want to point out that in my experience it appears to be
broken in various ways. I experienced  curious things.

I was hoping that it would be possible to generate via a script
directly the xml file I see that FontBook creates in 


but that was at a time I though the whole thing actually did work.

UPDATE: it now works again ! (Adventor, Pagella, Bonum, etc...)
and removing the Library from FontBook it immediately ceased
working. And re-adding it, it worked again. Don't know what

best wishes

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://tug.org/pipermail/tex-live/attachments/20150511/649394fd/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: Inconsolata.png
Type: image/png
Size: 73675 bytes
Desc: not available
URL: <http://tug.org/pipermail/tex-live/attachments/20150511/649394fd/attachment-0001.png>

More information about the tex-live mailing list