[tex-live] automake issues with $(AM_V_P)

Mirko Vogt tex at nanl.de
Mon Mar 9 20:29:57 CET 2015


I'm having issues compiling latest trunk (svn rev 36459):

configure: creating ./config.status
config.status: creating Makefile
config.status: creating kpathsea/c-auto.h
config.status: executing depfiles commands
config.status: executing libtool commands
make[3]: Entering directory '/compile/texlive-36470/texk/web2c/web2c'
/bin/bash: -c: line 4: syntax error near unexpected token `;'
/bin/bash: -c: line 4: `    if ; then :; else echo "  GEN
w2c/config.h"; fi; \'
Makefile:929: recipe for target 'w2c/config.h' failed
make[3]: *** [w2c/config.h] Error 1
make[3]: Leaving directory '/compile/texlive-36470/texk/web2c/web2c'

This seem to come from:
texk/web2c/web2c/Makefile.in:933:	    if $(AM_V_P); then :; else echo "
 GEN      $@"; fi; \

which expands to:
texk/web2c/web2c/Makefile:227:    if test -f "$$i"; then echo $$i; else
echo $(srcdir)/$$i; fi; \

I noticed Norbert had a similar problem once[1], which was solved by a
newer automake version. His problem was <AM_V_P> not being defined -
however I don't think that's the case here, still it seems to be related
to silent rules.
I get this error regardless whether I run autoreconf or not.

/bin/automake --version
automake (GNU automake) 1.15

Thanks a lot in advance!




More information about the tex-live mailing list