[tex-live] source build: context --version complains about unknown script

Ken Moffat zarniwhoop at ntlworld.com
Wed Jun 17 01:45:55 CEST 2015


I am one of those people who is anal enough to build everything from
source "because we can".  I also try to maintain texlive at beyond
linuxfromscratch [ 'BLFS' ] and for that I have some test scripts to
check if things are working, driven by a configure script so that I
do not try to run tests which will not work.

One of the problems I had in the past year was broken verions of
context (when I tried my tests in distro installs under qemu), and I
worked around that by checking that 'context --version' would
succeed.  I've just built 2015 for the first time, and was
astonished to see that this failed.  Running 'context --version'
from the command line I see:

mtxrun          | unknown script 'context.lua' or 'mtx-context.lua

Using find, I can see that I do have an mtx-context.lua in
texmf-dist/scripts/context/ula/ : do I need to run a command,
perhaps mtxrun with a particular argument, to make context usable ?


Nanny Ogg usually went to bed early. After all, she was an old lady.
Sometimes she went to bed as early as 6 a.m.

More information about the tex-live mailing list