[tex-live] Strange problem with the devnag preprocessor

Manfred Lotz manfred at dante.de
Fri Mar 28 12:00:27 CET 2014

On Fri, 28 Mar 2014 11:00:36 +0100
Zdenek Wagner <zdenek.wagner at gmail.com> wrote:

> Hello,
> after a long time I had to use again the devnag preprocessor. I did it
> yesterday evening on my x86_64 with Fedora 18. The first one in PATH
> is my own binary compiled several years ago and probably dynamically
> linked. It failed at word kAra.n and reported it as kAra.i saying that
> .i is illegal. The search shows that there is no .i in the document. I
> have therefore tried the x86_64 binary from TeX Live 2013 and the
> result was the same. After compiling the binary from the source it
> worked. A few minutes ago I did the test with the very same file on
> Fedora 17. I tried my own binary compiled several years ago as well as
> binaries from TL 2010, 2011, 2012, 2013, Al these binaries work fine.
> Do you have any explanation what might happen between Fedora 17 and
> Fedora 18 or whether the bug is somewhere else?
> On both these computers TL is installed on a SDD and all other x86_64
> binaries work.
> I have not tried it on Raspberry yet.

Hm, I tried this:



{\dn kAra.n}


No error msg from devnag and the devanagari looks good.

The system is Fedora 20, devnag is from TL 2013.

devnag doesn't seem to react to -V or so. 

manfred at hogwart /usr/local/texlive/2013/bin/x86_64-linux % ldd devnag 
	linux-vdso.so.1 =>  (0x00007fffd0735000)
	libc.so.6 => /lib64/libc.so.6 (0x000000345fa00000)
	/lib64/ld-linux-x86-64.so.2 (0x000000345f600000)
manfred at hogwart /usr/local/texlive/2013/bin/x86_64-linux % ls -l devnag 
-rwxr-xr-x 1 root root 30704 May  2  2013 devnag



More information about the tex-live mailing list