[tex-live] xelatex on raspberry cannot write pdf

Boris Veytsman borisv at lk.net
Thu Sep 19 07:03:16 CEST 2013

ZW> Date: Wed, 18 Sep 2013 22:38:37 +0200
ZW> From: Zdenek Wagner <zdenek.wagner at gmail.com>

ZW> I have just noticed a strange problem. If I run xelatex from tl2013 on
ZW> raspberry from LXDE, it complains that it cannot output something.pdf and
ZW> asks for another file name. Whatever file name I supply the error message
ZW> is the same. If I press ctrl-D, xelatex exits, PDF is not created but aux
ZW> and log are written. If I ssh from another computer while LXDE runs, I get
ZW> the same error. If I close LXDE while xelatex in the ssh session waits for
ZW> another file name and then push Enter, xelatex continues and the PDF is
ZW> written. I tried similar experiment with pdflatex and lualatex and they
ZW> work fine without any problem. The test file is simple:

Which TL do you run?  arm or armhf?  Raspbian uses hardware floating
point, so you do need armhf version on it.

Good luck


"Faith:  not *wanting* to know what is true."
		-- Friedrich Nietzsche

More information about the tex-live mailing list