[tex-live] Bug in release 20120903

Norbert Preining preining at logic.at
Wed Sep 5 00:22:50 CEST 2012

On Tue, 04 Sep 2012, tobilot wrote:
> To make it brief: I tried to install texlive on a server (gentoo)
> all the way into a user-home directory. I changed the default path
> values (under <D> -> (1)) to match the user directories where I have
> full write permissions.

THat is, you set it to:

> Time used for installing the packages: 00:37
> running mktexlsr $HOME/usr/local/texlive/2012/texmf-dist $HOME/usr/local/texlive/2012/texmf...
> writing fmtutil.cnf to $HOME/usr/local/texlive/2012/texmf-var/web2c/fmtutil.cnf
> writing updmap.cfg to $HOME/usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg
> writing language.dat to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.dat
> writing language.def to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.def
> writing language.dat.lua to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.dat.lua
> running mktexlsr $HOME/usr/local/texlive/2012/texmf-var $HOME/usr/local/texlive/2012/texmf-config $HOME/usr/local/texlive/2012/texmf-dist ...

so up to here all is fine.

> running updmap-sys...$HOME/usr/local/texlive/2012/bin/x86_64-linux/updmap-sys:
> line 23: $HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No
> such file or directory

Huuu, ther is no kpsewhich ... Do you have this directory?

> provider and they tried to execute kpsewhich with SSH and
> ./kpsewhich but this was NOT successful.

Of course -- if you run ./kpsewhich it means you are asking for
running it from the current dir, where it definitely is not present.

Try ssh-ing into it and type:
	which kpsewhich
and then
	ls $HOME/usr/local/texlive/2012/bin/x86_64-linux/
and send us the output.

> Then they made a try with strace and that's what the output was:

strace of a non-existing file ... umpf ... yes, thanks, we know
how that looks like .

> The support team says they think that the script looks for a
> directory or there are dependencies which are not correctly set.


> All the files which appears to be missing, are definitely physically there!



Can you send the output of:
	which tlmgr
and if something is found, the output of
	tlmgr conf

> Of course I set the pathvariable to "....bin/x86_64-linux:"

STOP!!! WHAT did you set your PATH to, *EXACTLY* ...

Best wishes


Norbert Preining                preining@{jaist.ac.jp, logic.at, debian.org}
JAIST, Japan                                   TeX Live and Debian Developer
gpg DSA: 0x09C5B094   fp: 14DF 2E6C 0307 BE6D AD76  A9C0 D2BF 4AA3 09C5 B094
The violent colour of one of Nigel Rees's jackets, worn when he thinks
he's being elegant.
			--- Douglas Adams, The Meaning of Liff

More information about the tex-live mailing list