[tex-live] Bug in release 20120903

tobilot tobilot at gmx.de
Tue Sep 4 20:39:32 CEST 2012

Hi list,
it is the first time I use this list. So when this list is not the proper way to adress my problem then just let me know!
To make it brief: I tried to install texlive on a server (gentoo) all the way into a user-home directory. I changed the default path values (under <D> 
-> (1)) to match the user directories where I have full write permissions.
But installation itself doesnt't went through fairly smooth, there were issues about 'no such file or directory' concerning mainly kpsewhich.
The install-logfile wrote:

Time used for installing the packages: 00:37
running mktexlsr $HOME/usr/local/texlive/2012/texmf-dist $HOME/usr/local/texlive/2012/texmf...
writing fmtutil.cnf to $HOME/usr/local/texlive/2012/texmf-var/web2c/fmtutil.cnf
writing updmap.cfg to $HOME/usr/local/texlive/2012/texmf-dist/web2c/updmap.cfg
writing language.dat to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.dat
writing language.def to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.def
writing language.dat.lua to $HOME/usr/local/texlive/2012/texmf-var/tex/generic/config/language.dat.lua
running mktexlsr $HOME/usr/local/texlive/2012/texmf-var $HOME/usr/local/texlive/2012/texmf-config $HOME/usr/local/texlive/2012/texmf-dist ...
running updmap-sys...$HOME/usr/local/texlive/2012/bin/x86_64-linux/updmap-sys: line 23: $HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No 
such file or directory
$HOME/usr/local/texlive/2012/bin/x86_64-linux/updmap-sys: line 24: $HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No such file or directory
Can't exec "kpsewhich": No such file or directory at $HOME/usr/local/texlive/2012/bin/x86_64-linux/updmap line 26.
updmap: Cannot find TEXMFROOT, aborting!
re-running mktexlsr $HOME/usr/local/texlive/2012/texmf-var $HOME/usr/local/texlive/2012/texmf-config...
pre-generating all format files (fmtutil-sys --all), be patient...$HOME/usr/local/texlive/2012/bin/x86_64-linux/fmtutil-sys: line 22: 
$HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No such file or directory
$HOME/usr/local/texlive/2012/bin/x86_64-linux/fmtutil-sys: line 23: $HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No such file or directory
$HOME/usr/local/texlive/2012/bin/x86_64-linux/fmtutil: line 216: $HOME/usr/local/texlive/2012/bin/x86_64-linux/kpsewhich: No such file or directory
$HOME/usr/local/texlive/2012/bin/x86_64-linux/fmtutil: line 395: /texconfig/tcfmgr: No such file or directory
fmtutil: config file `fmtutil.cnf' not found.
running package-specific postactions
postaction install script for dvipdfmx: perl /tlpkg/tlpostcode/dvipdfmx.pl
finished with package-specific postactions

whereas $HOME represents my user-homedirectory. I have just manually replaced this with the word $HOME in the above snippet.
I know its unusual to have another usr/local structure under $HOME but this is not causing the problem here.

As I am not very familiar with all that deep stuff I asked my server provider and they tried to execute kpsewhich with SSH and ./kpsewhich but this 
was NOT successful.
Then they made a try with strace and that's what the output was:

strace ./kpsewhich
execve("./kpsewhich", ["./kpsewhich"], [/* 26 vars */]) = -1 ENOENT (No
such file or directory)
dup(2)                                  = 3
fcntl64(3, F_GETFL)                     = 0x8002 (flags O_RDWR|O_LARGEFILE)
fstat64(3, {st_mode=S_IFCHR|0620, st_rdev=makedev(136, 0), ...}) = 0
0) = 0xf052d000
_llseek(3, 0, 0xf9730248, SEEK_CUR)     = -1 ESPIPE (Illegal seek)
write(3, "strace: exec: No such file or di"..., 40strace: exec: No such
file or directory
) = 40
close(3)                                = 0
munmap(0xf052d000, 4096)                = 0
brk(0x80b9000)                          = 0x80b9000
exit_group(1)                           = ?

The support team says they think that the script looks for a directory or there are dependencies which are not correctly set. They even tried it in 
their testing environment and this issue was reproducable
Other files like texindex were executable:

texindex --version
texindex (GNU texinfo) 4.13

Copyright (C) 2008 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.

I used this link with wget to get the latest texlive on my server:


There must be something wrong with variables which should normally get a specific path. According the install.log this must be in:
updmap-sys: line 23:
updmap-sys: line 24:
updmap line 26
fmtutil-sys: line 23
fmtutil: line 216
fmtutil: line 395
respectively in their symlinked target files.

All the files which appears to be missing, are definitely physically there!

OK, my problem is, I have not the knowledge to dig into all the code and therefore I hope someone in this list can help to fix this. I don't either 
know how and where to file a ticket in a bugtracker.

Of course I set the pathvariable to "....bin/x86_64-linux:"

Thanks and regards

More information about the tex-live mailing list