[tex-live] Installing TeX live on MacOS X

Angelo Graziosi angelo.graziosi at alice.it
Sun Jun 26 13:44:03 CEST 2011

Il 26/06/2011 1.24, Norbert Preining ha scritto:
> That is *really* strange ...and I am a hard time reproducing it, since
> as you said, on Linux it is working.
> Are you sure you don't have an old install-tl or so hanging around?

I have a local mirror (rsynced daily) of


It contains:

$ ls -l
-rwxr-xr-x  1 ... ...75112 14 giu 01.23 install-tl

> Can you run the install-tl with -v or -v -v and see iff it gives more
> info why the -force-platform does not work on darwin?

I can only use what you suggest whithout '-force-platform' option, i.e.

$ ./install-tl -v

$ ./install-tl -v -v

Both print:

D:Using shipped ./tlpkg/installer/wget/wget.universal-darwin for wget 
D:Using shipped ./tlpkg/installer/xz/xzdec.universal-darwin for xzdec 
D:Using system xz (not tested).
Installing TeX Live 2011 from: /Users/.../tlpretest_repo
Platform:  universal-darwin => 'universal binaries for MacOSX/Darwin'
Distribution: inst (compressed)
Directory for temporary files: /var/folders/.../-Tmp-/
Loading /Users/.../tlpretest_repo/tlpkg/texlive.tlpdb

Some day before I tried the -force...' option, there was an Apple 
upgrade from 10.6.7 to 10.6.8, if I remember correctly...

(Just for completeness, I received private mail from someone who tried 
'-force-platform x86_64-darwin' 10 days ago, and it worked and now he 
can't try because several network problems...)


More information about the tex-live mailing list