[tex-live] Installing TeX live on MacOS X

Angelo Graziosi angelo.graziosi at alice.it
Sat Jun 25 16:17:00 CEST 2011

Recently, I have done some installation of TL pretest on Mac OS X and 
have found something strange, but I am new to Mac OS X so perhaps I am 

The system is a MacBook pro with:

$uname -a
Darwin ... 10.8.0 Darwin Kernel version 10.8.0:.... RELEASE_X86_64 x86_64

If I install with:

$ sudo ./tlpretest_repo/install-tl

it installs 'universal-darwin', and all works fine...

But I have seen that also 'x86_64-darwin' is supported, so with choice 
<B>, I have tried to choose *only* 'x86_64-darwin': each time it selects 
also 'universal-darwin', i.e. 2 platforms.

Then I have tried to run the install script with:

$ ./tlpretest_repo/install-tl -force-platform x86_64-darwin     <== (*)

but it fails with:

./tlpretest_repo/install-tl: Extra argument '-force-platform 

trying ...-force-platform 'x86_64-darwin' does not help...

The strange things is that trying (*) on other OS, works. i.e. does not 

So is there a way to force the above platform? What am I missing?


More information about the tex-live mailing list