[tex-live] TeXLive 2011 and Solaris Intel---More info

Ettore Aldrovandi ealdrov at mail.math.fsu.edu
Wed Jun 8 18:16:37 CEST 2011

Hello All,

more information on TL 2011 and Solaris, both 10 and 11. I have
installed the pretest on both Solaris 10 and 11 on Intel.  (This is
updated information, somehow, hence the new thread.)

The installation on Solaris 11 (solaris 11 express) was performed on a
stock blank installation with minimal configuration (in VirtualBox, if
that matters).  The Solaris 10 one on a machine with S10 plus stuff from
SUN Freeware under /usr/sfw and CSW under /opt/csw.

On S10, the network installer failed with: "symbol not found: htonll",
as noted in a previous report. Building xzdec from source and replacing
the provided xzdec.i386-solaris with the rebuilt one allows the
installer to proceed.

The binaries, having being built on S11, fail due to missing libraries,
e.g. libXaw7.so.7, and many others, again as noted previously.  This
loading problem can apparently be solved by installing the libraries
from CSW and setting the appropriate variables/conf files for the
loader, however there are still missing symbols, even in the pdftex
binary.  Despite this, I have been able to compile a couple of test
files.  The case of xzdec above, however, suggests this is not a viable

I have successfully rebuilt the binaries, both 32 and 64 bits, after
having had to modify texk/kpathsea/Makefile.in to explicitly invoke gawk
instead of awk, and texk/dvisvgm/dvisvgm-1.0.8/src/Process.cpp to
explicitly include <signal.h> (as noted for FreeBSD as well). 

After rebuilding the system seems to work---except synctex, see below. 

On S11, there is a potential problem on a stock S11 installation.
Several binaries, for example pdftex, require libgcc_s.so.6 and
libstdc++.so.6, which are only installed if the gcc package is installed
AND the dynamic loader is appropriately configured to look into
/usr/sfw/lib and /usr/sfw/lib/64.  Otherwise the network installer
seemed to have worked, I wasn't monitoring.  However, it failed to
generate the ls-R files and build the formats.  After installing gcc and
reconfiguring the loader I was able to generate the ls-R files and the

After that, the system seems to work---except synctex, again.

About Synctex:

>From the limited testing I have done, it appears pdftex is generating
the correct .synctex.gz files (with absolute paths).  However the parser
bombs with "Bad Preamble" errors.  It appears to be specific to 2011: I
used the command "sync view" from TL 2009 on a .synctex generated by
2011 pdftex and it works.  I have no idea whether this is

I can provide more details, if needed, and perhaps upload the binaries,
with some hand-holding.


Ettore Aldrovandi
Department of Mathematics, Florida State University
1017 Academic Way		 *    http://www.math.fsu.edu/~ealdrov
Tallahassee, FL 32306-4510, USA * * aldrovandi at math dot fsu dot edu

More information about the tex-live mailing list