[tex-live] issue with fonts in TeXLive 2011

Zdenek Wagner zdenek.wagner at gmail.com
Sun Jul 31 13:05:56 CEST 2011

2011/7/31 Pablo Rodríguez <oinos at web.de>:
> Hi there,
> I have just installed TeXLive 2011. Congratulations and many thanks to
> all contributors for the excellent work.
> My OS is (still) Fedora 14. The problems I'm experiencing are that I
> cannot use system fonts on XeLaTeX.
> Since I have been using LuaLaTeX for months and system fonts worked
> there, I'm not sure whether system fonts didn't worked with XeLaTeX in
> TL2010.
> My issue is that fontconfig-2.8.0 seems only to be able to find fonts
> available that come with TL2011, but system fonts (under standard
> directory /usr/share/fonts/) aren't always found (fc-list finds some
> fonts and not other ones). "fc-cache -f" doesn't change anything.
Do you run fc-cache as a root or as a user? It may be slightly
different. I still use TL2010 but I hope there is no drastic
modification. I always run fc-cache without parameters and as root. I
use TL on CentOS 4, CentOS 5, and Fedora 13. I used it also on Fedora
Core 2 and it always worked. The only problem was latest DejaVu fonts
because they require newer version of fontconfig than distributed with
Fedora Core 2 and CentOS 4.

> Could anyone be so kind to tell me how to fix this?
> Many thanks for your help,
> Pablo
> --
> http://www.ousia.tk

Zdeněk Wagner

More information about the tex-live mailing list