[tex-live] tl-2011: updmap needs perl-5.8.8 or newer

Harald Koenig koenig at tat.physik.uni-tuebingen.de
Tue Jul 26 17:13:15 CEST 2011

On Jul 26, Harald Koenig wrote:

> installing/updating tl-2011 on a linux system with an old perl version (5.8.4)
> I run into this error:
> 	$ updmap-sys 
> 	Error in option spec: "setoption=s{1,2}"

update FYI: 
a quick search through tl-2011 with

	find /usr/local/texlive/2011  -name \*.pl | xargs grep '=.{.*=>'

seems to suggest that updmap is the only script which uses that 'new' getopt syntax.

more updmap and installer woes -- short story:

while the install-tl script claims that updmap-sys worked just fine:

	running updmap-sys...done

updmap-sys really just barfed and did not work at all:-(

and now the long story (since you like Getopt::Long;-)))

I wondered why I noticed that error only now when doing the first "tlmgr update",
so I did another "clean" installation of tl-2011 and surprise: there was no error
for updmap-sys (at least the install output/log didn't show an error):

	mktexlsr: Updating /usr/local/texlive/2011/texmf-config/ls-R... 
	mktexlsr: Updating /usr/local/texlive/2011/texmf-var/ls-R... 
	mktexlsr: Done.
==>	running updmap-sys...done
	re-running mktexlsr /usr/local/texlive/2011/texmf-var /usr/local/texlive/2011/texmf-config...
	mktexlsr: Updating /usr/local/texlive/2011/texmf-config/ls-R... 
	mktexlsr: Updating /usr/local/texlive/2011/texmf-var/ls-R... 
	mktexlsr: Done.
	setting up ConTeXt MkIV cache with mtxrun --generate ...

one explanation might be that the TL installation does not use it's newly installed version 
of updmap but an older version of updmap which is in the search path too.

after the finised tl-2011 installation it looks like this:

	root at atuin 2011 # type -a updmap
	updmap is /usr/local/texlive/2011/bin/x86_64-linux/updmap
	updmap is /usr/local/texlive/2010/bin/x86_64-linux/updmap
	updmap is /usr/local/bin/updmap
	updmap is /usr/bin/updmap

(/usr/local/bin/ is an old "real" teTeX version and /usr/bin/ keeps the texlive-2010
which gets shipped by opensuse 11.4).

so I did remove *all* of those old updmap and updmap-sys versions 
and restarted the 2011 installation again from scratch...

but again, updmap-sys does not report an error:

	mktexlsr: Done.
	running updmap-sys...done
	re-running mktexlsr /usr/local/texlive/2011/texmf-var /usr/local/texlive/2011/texmf-config...

why ????

finally strace'ing the whole tl installation shows:

	$ egrep '^execve|^write|^exit'  /tmp/tl/O1.32581  | cut -c-120
	execve("/usr/local/texlive/2011/bin/x86_64-linux/updmap-sys", ["updmap-sys", "--nohash"], ["LESSKEY=/etc/lesskey.bin", "
	execve("/usr/local/texlive/2011/bin/x86_64-linux/updmap", ["updmap", "--nohash"], ["LESSKEY=/etc/lesskey.bin", "MANPATH=
	execve("/usr/local/texlive/2011/bin/x86_64-linux/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--n
	execve("/usr/local/texlive/2011/bin/x86_64-linux/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--n
	execve("/usr/local/texlive/2010/bin/x86_64-linux/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--n
	execve("/home/koenig/bin/amd64-linux/suse114/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--nohas
	execve("/home/koenig/bin/amd64-linux/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--nohash"], ["L
	execve("/home/koenig/bin/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--nohash"], ["LESSKEY=/etc/
	execve("/usr/local/bin/perl", ["perl", "/usr/local/texlive/2011/bin/x86_64-linux/updmap", "--nohash"], ["LESSKEY=/etc/le
	write(2, "Error in option spec: \"setoption=s{1,2}\"\n", 41) = 41
	exit_group(9)                           = ?

so the updmap run completely failed (with non-zero exit status), but the installer log
only shows

	running updmap-sys...done

so, please 
(a) fix both updmap not to use that repeatable option arguments and
(b) fix install-tl to check exit status and show errors like this...

"I hope to die                                      ___       _____
before I *have* to use Microsoft Word.",           0--,|    /OOOOOOO\
Donald E. Knuth, 02-Oct-2001 in Tuebingen.        <_/  /  /OOOOOOOOOOO\
                                                    \  \/OOOOOOOOOOOOOOO\
                                                      \ OOOOOOOOOOOOOOOOO|//
Harald Koenig                                           //  /     \\  \
koenig at tat.physik.uni-tuebingen.de                     ^^^^^       ^^^^^

More information about the tex-live mailing list