[tex-live] [texhax] ! LaTeX error: File 'rcs.sty' not found.

John H Harris jhharris at unencumberedDesign.com
Mon Mar 15 20:12:38 CET 2010

Hello Vladimir and Zdenek,

Zdenek wrote:

   It does not matter what shell is used, mktexlsr works the same way.

Yes, but for Vladimir, I ran it from cmd, with the same result.

Vladimir wrote:

   And again, this is strange. Why 'texmf-dist/doc/context/manuals/...' has

   Check environment variables (Windows and your tool): run in cmd.exe and
   in your tool 'set' command.

I have attached the output from each, cmdset.txt and shset.txt,
respectively. My Bourne shell has additional variables defined in its
profile script. Cmd set was run from a cmd launched from the Windows
GUI, and so should have no extra baggage.

   May be you don't have permission to write onto file

No, I do; I can actually touch it. I also ran "attrib -r * /D /S" on

   > > and I still get the rcs.sty-not-found error from latex.exe.
   Always use
   prompt$ kpsewhich rcs.sty
   to check if there is such file (read: could be found by texlive).

Ok. I still get no output from "kpsewhich rcs.sty".

   You could redefine TEXMFHOME, in TEXMFMAIN/web2c/texmf.cnf.

To what? That expands to C:/TeXLive/2009/texmf/web2c/texmf.cnf . I had
to remove the Windows extension binding between .cnf and Autodial to be
able to see this properly. I find

   % This used to be HOMETEXMF.
   TEXMFHOME = ~/texmf

What should I change TEXMFHOME to? How does kpathsea do tilde expansion?
For me, HOME=c:/home/jhharris . It seems a dangerous and confusing to
use tilde notation in a configuration file.

   These variables look good (expect last one: why
   'texmf-dist/doc/context/...' here?). Check your

As I mentioned earlier, I set the system environment variable TEXMFDBS
to include all the directories where I found ls-R files.
C:/TeXLive/2009/texmf-dist/doc/context/manuals/reference/en/ has an ls-R
file. I will remove it from the TEXMFDBS list.

   Check if you have permissions to write to these directories. And run
   mktexlsr (or texhash) from cmd.exe.

Ok. Still no output from "kpsewhich rcs.sty".

Zdenek wrote:

   The fastest solution is to delete all ls-R files from all TeX tress as
   admin and then call mktexlsr as normal user. Be sure that the
   directories themselves are writable.

TeXLive was installed with, and is normally used with, admin privileges.

I renamed C:/TeXLive/2009/texmf-config/ls-R (which had a "Cannot
open...to write" message) to .../ls-R.off and ran
mktexlsr. It did not create a new ls-R.

Aha! I note that, in the TEXMFDBS variable, the two "Cannot open" paths
begin with a space character. I cleaned it up and ran mktexlsr and got no
"cannot open" messages this time.

But still no kpsewhich rcs.sty output. I guess that is progress.

I think it is time to try a reinstallation. My fear here is that I
cannot be sure I have a clean machine. While troubleshooting the present
problem, I found several bits of detritus from former TeX Live
installations, including my last, 2007. There where environment
variables, directories, files. Is there a checklist for cleaning up?
I do not trust the uninstall script.

Thanks again


-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: cmdset.txt
URL: <http://tug.org/pipermail/tex-live/attachments/20100315/e81f8d22/attachment.txt>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: shset.txt
URL: <http://tug.org/pipermail/tex-live/attachments/20100315/e81f8d22/attachment-0001.txt>

More information about the tex-live mailing list