[tex-live] Error : "I can't find the format file `latex.fmt'!

George N. White III gnwiii at gmail.com
Mon Aug 30 12:27:37 CEST 2010

On Sun, Aug 29, 2010 at 10:35 AM, Fatih Arslan <farslan at pardus.org.tr> wrote
> Hi,
> I'm trying to build a package from the gentoo ebuild and eclasses. I'm
> not using gentoo, I just follow the codes and the bash scripts in the
> eclasess. I've installed successful all the necessary modules and files.
> But I've have problem, which I've tried to explain below.

This does not sound like an easy thing to do -- is there a reason not to
use CTAN texlive?

> As the subject said, i can't run latex. I've tried several things
> wihtout any success. Below you see the error output, after that you will
> see the command's that I execute and the following outputs of this
> execution.
> error:
> ikpathsea: Running mktexfmt latex.fmt
> I can't find the format file `latex.fmt'!
> [...]
> # echo $TEXINPUTS
> output: nothing

Normally the TEX... variables are not set in the shell but by
loading texmf.cnf in the tex-related programs.
You should use kpathsea debugging to see what is really
going on.

> I guess it has something to do with TEXINPUTS variables. Actually there
> are no variables set. I guess that's why fmtutil doesn't work at all.
> Should i set some variables and the try to install texlive from scratch ? I
> guess that these empty variables causes the system not to create the
> .fmt files.
> What should I do ?

What is you want to accomplish?  If you just want to get a current TeX
system (and have internet access), there are easier methods.

> Thanks in advance
> Regards
> --
> Fatih Arslan

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list