[tex-live] Error : "I can't find the format file `latex.fmt'!

Fatih Arslan farslan at pardus.org.tr
Sun Aug 29 15:35:13 CEST 2010


I'm trying to build a package from the gentoo ebuild and eclasses. I'm
not using gentoo, I just follow the codes and the bash scripts in the
eclasess. I've installed successful all the necessary modules and files.
But I've have problem, which I've tried to explain below.

As the subject said, i can't run latex. I've tried several things
wihtout any success. Below you see the error output, after that you will
see the command's that I execute and the following outputs of this

ikpathsea: Running mktexfmt latex.fmt
I can't find the format file `latex.fmt'!

# locate latex.fmt
output: nothing (didn't find)

Thus i ran fmtutil to create this file

# fmtutil --cnffile /usr/share/texmf/fmtutil/format.texlive-latex.cnf --fmtdir /usr/sharetexmf-var/web2c/ --all

output: nothing (blank page)

(where format.texlive-latex.cnf contains this lines) 
latex   pdftex  -       "-translate-file=cp227.tcx *latex.ini"
pdflatex        pdftex  -       "-translate-file=cp227.tcx *pdflatex.ini"
dvilualatex     luatex  -       "dvilualatex.ini"
lualatex        luatex  -       "lualatex.ini"

# texconfig init latex

output: nothing found

# texhash

texhash: Updating //etc/texmf/ls-R... 
texhash: Updating /usr/share/texmf/ls-R... 
texhash: Updating /usr/share/texmf-dist/ls-R... 
texhash: Updating /usr/share/texmf-site/ls-R... 
texhash: Updating //var/lib/texmf/ls-R... 
texhash: Done.

# kpsewhich texmf.cnf

file: http://cekirdek.pardus.org.tr/~farslan/texmf.cnf

# kpsewhich fmtutil.cnf

file: http://cekirdek.pardus.org.tr/~farslan/fmtutil.cnf

#pdfetex -ini   -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini


pdfetex -ini   -jobname=latex -progname=latex -translate-file=cp227.tcx *latex.ini
This is pdfTeX, Version 3.1415926-1.40.10 (Web2C 2009) (INITEX)
    entering extended mode
    ! I can't find file `latex.ini'.
    <*> *latex.ini

# kpsewhich latex.ini

output: nothing

# kpsewhich -var-value TEXINPUTS

output: nothing


output: nothing

I guess it has something to do with TEXINPUTS variables. Actually there
are no variables set. I guess that's why fmtutil doesn't work at all.
Should i set some variables and the try to install texlive from scratch ? I
guess that these empty variables causes the system not to create the
.fmt files.

What should I do ? 

Thanks in advance

Fatih Arslan

More information about the tex-live mailing list