[tex-live] tlinfra update done

Dan Luecking luecking at uark.edu
Sun Feb 15 04:57:05 CET 2009

Karl Berry (karl at freefriends.org) wrote

>We updated the infrastructure packages on tlnet last night.  The new
>versions is on tug.org now and will make its way around CTAN in due
>Windows users should run the update-tlmgr-latest.exe recovery executable
>to update the infrastructure packages.
>We hope this will
>1) fix the tex4ht-on-gnu/linux woes, and
>2) make updates on Windows simpler/more reliable.

I ran the update-tlmgr program (8:30pm CST, 13 Feb 09) and then
   tlmgr update --all
There were 34 updates, which seemed proceeded without incident
(except for those pesky make_container messages) until the very
end. Then there were these 6 lines of screen messages:

4NT: C:\TL2008\temp\updater-w32.bat [107] unknown command ":remove_src_doc"
TeX Live infrastructure update in progress
4NT: C:\TL2008\temp\updater-w32.bat [107] unknown command ":untar"
4NT: C:\TL2008\temp\updater-w32.bat [107] unknown command ":incltlpobj"
Update complete.
4NT: C:\TL2008\temp\updater-w32.bat [97] unknown command "2"

I see two problems with this:
  1. No new window was opened as the second and third lines seem to
     assume; instead the batch file updater-w32.bat appeared to run
     in the current shell (which was 4NT.exe).
  2. If the batch file was written exclusively for cmd.exe, then
     cmd.exe should probably be called to run it.

4NT.exe is supposed to be mostly compatible with cmd.exe batch file
syntax, but perhaps not completely. The lines that triggered errors were
[97]  2>nul del temp\w32_tar.exe temp\__BACKUP_*
[107] call %~1 %2 %3 %4 %5

The first seems completely wrong to me, but perhaps cmd.exe accepts it.

The second is part of the subroutine ":foreachpkg", which is called
with %1 equal to the commands complained about above.

I supposed the update was not complete, so I ran
   tlmgr update --all
again, but this time in a cmd.exe shell. It repeated the infrastructure
update. The messages this time were:
TeX Live infrastructure update in progress
[1/1] update: bin-kpathsea (11845 -> 12107)
Update complete.
Again, no new window was actually opened.

One wonders what people would experience who have their command
line provided by a completely different shell than cmd or 4NT.


Daniel Luecking
University of Arkansas
Fayetteville, AR 72701 USA

More information about the tex-live mailing list