[tex-live] tlmgr update --self in 4NT window.

Dan&Jan Luecking luecking at uark.edu
Wed Aug 5 21:13:05 CEST 2009

>2009/8/4 Dan Luecking 
><<http://tug.org/mailman/listinfo/tex-live>luecking at uark.edu>:
> >
> > In a 4NT window (under winXP, SP3), the command
> >  tlmgr update --self
> > produces an error (lines 5-6 below):
> >
> >  tlmgr: installation location 
> <ftp://ftp.math.utah.edu/pub/texlive/tlnet>ftp://ftp.math.utah.edu/pub/texlive/tlnet
> >  Preparing TeX Live infrastructure update...
> >  TeX Live infrastructure update in progress...
> >  'wrev' is not recognized as an internal or external command,
> >  operable program or batch file.
>No idea, where does this come from. Most likely harmless. Did it 
>happen before?

It happened in two of my available computers. I just tried
it on a third and it didn't happen. I don't know why.

The only place I could find the string 'wrev' is in
tl-updater.bat as the name of the 5th parameter of foreachpkg
and the 4th parameter of updateinfo and restoreinfo.

Could it be because of unescaped redirection symbols? For example,
line 173
   set "infomsg= -> %~4"
and 176
   set "infomsg=%infomsg:>=^>%"

> >  [1/1] update: texlive.infra.win32 (14500 -> 14520)
> >  TeX Live infrastructure update complete.
> >
> > The update seems to proceed anyway, but I cannot be sure it is
> > complete as there is no way of telling what it is doing nor
> > any way of finding out what it is supposed to be doing.
>You can make the updater more chatty with 'tlmgr -v ...', this will
>enable debugging also in the batch updater script. Full description of
>the update process can be found in
>.../texmf/scripts/texlive/updater-w32 if you are interested in more

I had read that, so I know the process, but it doesn't
say what actual files are changed by that process. Nor can
one see from any messages whether those files are changed.
Thus, I have no way to check if an update has taken place
(apart from version numbers in *.tlpobj, which only proves
those files were changed).

> > The same command in a cmd.exe shell proceeds without error.

It is hard to check if it fails in 4NT and succeeds in cmd,
because one can only do one after the other. When I saw the
error in 4NT, I rolled back one version (using a previously
saved update-tlmgr-r*.exe) and tried in cmd. The latter worked
without error, but I can't be sure they were run under the same
conditions. I have not yet tried running cmd first.

>That is strange. At the very begining the updater script restarts
>itself in cmd.exe to avoid issues with 4NT amongst other things.
>Anything after 'DO NOT CLOSE THIS WINDOW!' is actually executed in
>cmd.exe, so there should be no differences there.

What exactly is "the updater script"? If you mean updater-w32.bat,
I don't see that in there (though it does appear in updater-w32,
which I thought was supposed to be a copy of it). Which one is
actually invoked? On the system I'm answering from, the .bat is
older, and there are differences in the description of the update


Dan Luecking
Fayetteville, Arkansas 

More information about the tex-live mailing list