[tex-live] tlmgr update --self in 4NT window.

T T t34www at googlemail.com
Wed Aug 5 12:05:14 CEST 2009

2009/8/4 Dan Luecking <luecking at uark.edu>:
> In a 4NT window (under winXP, SP3), the command
>  tlmgr update --self
> produces an error (lines 5-6 below):
>  tlmgr: installation location ftp://ftp.math.utah.edu/pub/texlive/tlnet
>  Preparing TeX Live infrastructure update...
>  TeX Live infrastructure update in progress...
>  'wrev' is not recognized as an internal or external command,
>  operable program or batch file.

No idea, where does this come from. Most likely harmless. Did it happen before?

>  [1/1] update: texlive.infra.win32 (14500 -> 14520)
>  TeX Live infrastructure update complete.
> The update seems to proceed anyway, but I cannot be sure it is
> complete as there is no way of telling what it is doing nor
> any way of finding out what it is supposed to be doing.

You can make the updater more chatty with 'tlmgr -v ...', this will
enable debugging also in the batch updater script. Full description of
the update process can be found in
.../texmf/scripts/texlive/updater-w32 if you are interested in more

Normally, if you don't see rollback attempt to previous revision in
the output, all should be good. However, I agree with you that there
is no easy way to track all the actions of updater. What I could do is
to write a log file with normal and debug output. It should make
troubleshooting easier. I will look into it.

> The same command in a cmd.exe shell proceeds without error.

That is strange. At the very begining the updater script restarts
itself in cmd.exe to avoid issues with 4NT amongst other things.
Anything after 'DO NOT CLOSE THIS WINDOW!' is actually executed in
cmd.exe, so there should be no differences there.

> Updating with update-tlmgr-*.exe has never produced any errors.
> Versions:
> (1) Yesterday I ran update-tlmgr-r14511.exe, after which
>    tlmgr --version reported revision 14500.
> (2) Today I ran tlmgr update --self with the above error message.
>    Afterwards tlmgr --version also reported revision 14500
> (3) After (2), I ran update-tlmgr-r14520.exe and tlmgr --version
>    still reports revision 14500.

That is fine, even though it looks strange, I agree. There were some
updates to infrastructure files but no updates to tlmgr.pl itself, so
its revision number has not changed. If you run 'tlmgr show
texlive.infra texlive.infra.win32' it should report correct revisions
for the infrastructure packages.

Norbert, perhaps 'tlmgr --version' should report also infractructure revision?

> (4) Under 4NT, the ver command gives
>      4NT  8.02.106   Windows XP [Version 5.1.2600]
>      4NT Build 106   Windows XP Build 2600  Service Pack 3
> [I will soon update my 4NT and you will probably see lots fewer
> reports of such problems.]

I do all my tests with TCC LE 10.00.52, I don't have access to 4NT.
For any incompatibilites between 4NT versions I have to rely solely on
bug reports.



More information about the tex-live mailing list