[tex-live] tlmgr update --self in 4NT window.

Dan Luecking luecking at uark.edu
Wed Aug 5 00:23:15 CEST 2009

In a 4NT window (under winXP, SP3), the command
   tlmgr update --self
produces an error (lines 5-6 below):

   tlmgr: installation location ftp://ftp.math.utah.edu/pub/texlive/tlnet
   Preparing TeX Live infrastructure update...
   TeX Live infrastructure update in progress...
   'wrev' is not recognized as an internal or external command,
   operable program or batch file.
   [1/1] update: texlive.infra.win32 (14500 -> 14520)
   TeX Live infrastructure update complete.

The update seems to proceed anyway, but I cannot be sure it is
complete as there is no way of telling what it is doing nor
any way of finding out what it is supposed to be doing.

The same command in a cmd.exe shell proceeds without error.
Updating with update-tlmgr-*.exe has never produced any errors.

(1) Yesterday I ran update-tlmgr-r14511.exe, after which
     tlmgr --version reported revision 14500.
(2) Today I ran tlmgr update --self with the above error message.
     Afterwards tlmgr --version also reported revision 14500
(3) After (2), I ran update-tlmgr-r14520.exe and tlmgr --version
     still reports revision 14500.
(4) Under 4NT, the ver command gives
       4NT  8.02.106   Windows XP [Version 5.1.2600]
       4NT Build 106   Windows XP Build 2600  Service Pack 3

[I will soon update my 4NT and you will probably see lots fewer
reports of such problems.]


Daniel H. Luecking
Department of Mathematical Sciences
University of Arkansas
"Dubito ergo cogito, cogito ergo sum" --Descartes

More information about the tex-live mailing list