[tex-live] prolems running latex in tex-live

George N. White III gnwiii at gmail.com
Sat Sep 20 13:35:52 CEST 2008

2008/9/20 Zdenek Wagner <zdenek.wagner at gmail.com>:

> 2008/9/20 Ralph Boland <rpboland at gmail.com>:
>> Apologies for sending this a second time.  The first time I accidentally hit
>> the send button.
> Such errors usually happen if you have both teTeX (or some traces of
> teTeX) and TeXLive and PATH is not set correctly. Be sure that you
> have /usr/local/texlive/200$x/bin/$arch (supply the correct year and
> arch) at the beginning of PATH.

The OP was not clear about which version(s) of TeX have been installed.
likely candidates include:

 Ubuntu/Debian packaged teTeX

      In this case the binaries end up in /usr/bin

 Ubuntu/Debian packaged TL

      In this case the binaries end up in /usr/bin

TL installed from CTAN

      In this case, the binaries end up in

>> I am running tex-live on a ubuntu 7.10 system.
>> I had had tex-live running successfully for a while but recently tried to
>> add a number of .cls and .sty files.

Again, important details are lacking -- were these files added using packages
or by copying to ??

>> Once I added these files I was able to use them while running lyx (which
>> generates .tex files)
>> Eventually I got around to running latex on my .tex files.
>> When I did I got the following errors:
>>         kpathsea: Running mktexfmt pdflatex.fmt
>>         tcfmgr: config file `tcfmgr.map' (usually in $TEXMFMAIN/texconfig)
>> not found.
>>         fmtutil: config file `fmtutil.cnf' not found.
>> Advice on the web advised me to reinstall tex-live which I did but it did
>> not help.

I hate that -- reinstalling without first understanding the source of
the problem
often simply compounds the problems.   It may still be possible to do some
analysis of the .log files from the files processed using lyx.  Look for the
version of the tex program, directories from which files were loaded.

It would appear that lyx is using a different TeX system or perhaps just
a "private" configuration.

>> Eventually I discovered the texconfig command.
>> First I tried running texhash from inside texconfig but to no avail.
>> then I ran conf to show the configuration; the output is shown below.
>> Some of the  kpathsea variables have odd settings as far as I know.
>> In particular:
>>         TEXMFVAR=/home/rocky/.texmf-var
>>         TEXMFCONFIG=/home/rocky/.texmf-config
>> Neither of the above files exist in my home directory (rocky).

These should be directories, but may not be used as their purpose
is to hold user-specific settings.  Many users make the mistake of
running configuration commands as root, so the directories may
be in the home directory of the root user's account.   Alternatively, if the
-sys versions of the tools were used, then the relevant variables


>> Questions
>>         1) Are these settings the source of my problem.
>>          2) If they are then how do I get them set correctly.
>>          3)  If they are not how do I do a proper reinstall.
>>               I assume I have modified or created a file somewhere
>>               that is affecting the reinstall but I don't know which file.

There may be two different TeX systems installed in different locations,
or they may be mingled in one location, in which case the package manager
may have left .dpkg-old or .dpkg-new files.

You can use  the locate command to search for multiple copies of key files
such as texmf.cnf.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list