[tex-live] texdoc error

Philip TAYLOR P.Taylor at Rhul.Ac.Uk
Mon Sep 1 11:53:43 CEST 2008

Manuel Pégourié-Gonnard wrote:

> Hmm. Can you please try lauching
 > start "" "c:\path\to\minitoc.pdf"

Works fine, as does

	start c:\path\to\minitoc.pdf

What does not work (brings up a CMD box) is

	start "c:\path\to\minitoc.pdf"

> in a cmd window and see it the same problem happens? Cause that's what texdoc
> is doing (try texdoc -v minitoc to confirm) 

Cannot confirm : "texdoc -v minitoc" does
nothing detectable apart from report the version.

The best I can accomplish by way of a trace is

> C:\Documents and Settings\Administrator>texdoc -n32767 minitoc
> texdoc debug1: start "" "D:\TeX\Live\2008\texmf-dist\doc\latex\minitoc\minitoc.pdf"
> C:\Documents and Settings\Administrator>

which died as before.  The same "start" command copied and pasted
into the existing CMD window works fine.

> and AFAIK it's the recommended way
> of openning documents on windows. At least, it worked when I did tests.

What is the purpose of the leading '""' ?  Is this needed
to work around the need for quotes around the path when
the latter contains spaces ?

> Are other files working at all with texdoc + AR?

I haven't tried any (I never use TeXdoc); if you can
suggest a few, I will try them.

Akira Kakuto wrote:

 > Does
 > texdocc minitoc
 > also fail?

No, that works fine.  The corresponding trace is :

> C:\Documents and Settings\Administrator>texdocc -v minitoc
> I now display a document by the command
> cmd /c start d:/TeX/Live/2008/texmf-dist/doc/latex/minitoc/minitoc.pdf

I am just setting up a duplicate setup with forced spaces
in the path (".../texmf dist/...") to see how this will
affect things ...

** Phil.

More information about the tex-live mailing list