[tex-live] TeX Live 2008 testing - problems downloading

George N. White III gnwiii at gmail.com
Sun Jun 29 14:21:05 CEST 2008

On Sat, Jun 28, 2008 at 10:57 PM, Reinhard Kotucha
<reinhard.kotucha at web.de> wrote:
> Karl Berry writes:
>  >     wgetrc still has tries=2.
>  >
>  > Obviously I don't know what you "grabbed", but I changed it to tries=4 a
>  > couple days ago (and that is what is in the install-tl zip/tgz).

I downloaded install-tl-unx.tar.gz from a mirror site yesterday, but
looking at the dates,
there is nothing since Jun 13th.  The install-tl.zip has newer files.
 This morning,
the files on ctan.tug.org were newer than the ones I downloaded from a mirror

>  >
>  >     to tries=20 and had success (using Fedora 8 linux) with a minimal
>  >     install in just one try (wish I had done that on Thursday!).
>  >
>  > Very interesting.  I had expected that if something failed with a couple
>  > of tries, trying 20 times would simply be a useless waste of time.

Well, I have not been able to do a full install even with tries=20.  I tried
the default (mirror) and also a couple North American mirrors (twice each).

I think the net installer should come with the caveat that it only work with
reliable access to a CTAN archive.  Failing that, there is the DVD or a
local mirror on your site's intranet (see below).

> But if someone succeeded to download 99% of the stuff, he is certainly
> more happy with tries=$\infty$.
> I do not see any good reason to divert from the default values
> provided by wget.  It seems that they are good.

We use wget (ftp) at work to grab remote sensing images (typically
a few 100 MB) from a (restricted) NASA site.  Approximately 1% of
the downloads fail.  All this is using one very big and very reliable
server.  The failures are the result of packets not being delivered,
resulting in a timeout.  I think the timeout is controlled by the TCPIP
protocol, not any wget parameter, and the best metric for the chances
of a problem is the number of hops to the server.

I tried just downloading files (at home, different provider from work) from a
couple N. Am. archive sites using bare wget (linux, default settings) and never
made it past the b's.   I was, however, able to get all the files with a few
restarts using "wget -N .." (which skips already downloaded files).

I tried putting the downloaded files on the local apache server:

$ du -sk tlnet/tldev/tlpkg/
1008980	tlnet/tldev/tlpkg/
# ln -s /usr/local/texlive/2008/tlnet /var/www/html

$ ./install-tl -gui -url http://localhost/tlnet/tldev

This worked, and xetex is creating pdf's with letter paper,
but now context is creating a4 pdf's (perhaps my fault, as
I put the 2008.06.11 version in texmf-local).

Other observations:

install-tl claims to support debug flags -d -dd -ddd, but they don't work:

I notice that install-tl uses /tmp.  On some sites, users are not allowed to
write in /tmp.  Generally they will have something like TMPDIR=$HOME/tmp.
I'm surprised that perl doesn't respect TMPDIR.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list