[tex-live] Bugs in install-tl for win32

Dan Luecking luecking at uark.edu
Tue Jun 24 23:26:54 CEST 2008

Dear TeXLive Developers:

I have been testing the win32 version of install-tl found at

These are my observations.

I unpacked install-tl.zip, copied the resulting directory tree
to C:\TLtemp\ changed to that directory and ran install-tl.bat
without arguments. I expected a console mode program, but a GUI
window appeared (which was OK). I selected scheme-basic and
gave C:/TL2008 for the base directory. I toggled letter paper to
Yes, and the remaining 3 choices to No (don't create formats, don't
download macro documentation or sources).

I tried this a few times on several different days (downloading a new
instal-tl.zip each day). This always failed. The first couple of
times it halted at trying to get luatex.tar.lzma, which it said it
could not find. Other times it proceeded to postinstallation processing
and complained of a file not found. Usually this was either
The console output simply froze after displaying an error meassage
plus several messages pointing to lines in various perl files/modules.
The files complained about did indeed not exist.

When I pressed CTRL-C in the console, no .log file was created.
If I pressed the Quit button in the GUI window, the log was created
but it didn't contain the error report. In neither case was I able to
find out what the URL actually resolved to. The log file contains only
There were several console messages that looked like
   tar: : File not found in archive
These message did not appear in the log. They never mention any file
name. I tried to get more verbose poutput using install-tl with the
debug options -d -dd or -ddd, but that only produced the help screen
and never started the installation program.

I also tried using the -url option, selecting http://www.ctan.org.
This time the installation proceeded farther. Right up to running
updmap-sys, which produces the following output for several files
(backslashes all were indeed doubled):
  dir /b: No such file or directory
  dir /s: No such file or directory

Those files do actually exist. Moreover, psfonts.map, etc., do
seem to be correctly and newly created. Thus these messages seem

The last few lines on the console were:
Seting default paper to letter
C:/TL2008/texmf/scripts/texlive/texconf.tlu:42 module 'texlive.getopt' not
    no field package.preload['texlive.getopt']
    no file 'C:/texmf/scripts/texlive/lua/texlive\getopt.tlu

The slashes are exactly like that. The file
does in fact exist.

The GUI window then said it was finished. Clicking OK ended the install
but no log file was created. Afterward the current shell's PATH variable
was unchanged. The master PATH variable, however, was changed: the old
texmf bin directory was removed and the new one placed on the end.

Exiting and restarting the shell put the new PATH into effect. Running
updmap-sys had exactly the same screen output as before. However,
timestamps on the files show they were in fact newly generated.

The default paper setting that failed at the end of the install
could be run successfully by creating a universal script starter
named texconf.bat and running that. I later found that I could run
   texlua C:\TL2008\bin\win32\tl-w32-wrapper.texlua texconf
but that does not work if the "C:" is omitted!


Daniel H. Luecking
Department of Mathematical Sciences
University of Arkansas
"Dubito ergo cogito, cogito ergo sum" --Descarte

More information about the tex-live mailing list