[tex-live] problems installing TL08 on WinXP

George N. White III gnwiii at gmail.com
Thu Aug 14 19:39:56 CEST 2008

On Thu, Aug 14, 2008 at 1:44 PM, Maxwell, Adam R <adam.maxwell at pnl.gov> wrote:
> On 08/14/08 06:11, "George N. White III" <gnwiii at gmail.com> wrote:
>> On Wed, Aug 13, 2008 at 1:35 PM, Maxwell, Adam R <adam.maxwell at pnl.gov> wrote:
>>> I tried using the bootstrap installer as recommended by this page:
>>> http://gentoo.chem.wisc.edu/tex-archive/systems/texlive/tlnet/tldev/README
>>> to install TL 2008 on a Windows XP Pro system, but the install fails.  It
>>> looks like none of the formats are created, and manual attempts to run
>>> updmap-sys or tlmgr from the Windows shell result in " No appropriate script
>>> found." messages.  Log file attached.
>>> I first tried a medium install with some additional packages added via the
>>> installer GUI, then tried a full install with the same results.  Let me know
>>> if I can provide additional info; using Windows is not my forte.  I'm using
>>> TL08 on Mac OS X, and was hoping to get a Windows-using colleague to use it
>>> as well.
>> Did your colleague have some other version of TeX installed?  There may be
>> some environment variables that conflict with the new version.
> I'm actually using my own Windows box as a guinea pig, since I don't care if
> it has a working TeX; now that you mention it, I have (had) an old version
> of MikTeX installed on it.  I'd checked environment variables and didn't see
> anything obviously fishy.
>> I see that the
>> install directory is "C:\Program Files\\texlive\2008\bin\win32".  While this
>> should work, I think some ConTeXt tools have problems with the space in
>> the path, so I used F:\texlive\2008 for my own (more successful) testing.
> Installing to "Program Files" was the default setting, which I thought was
> odd as well.  I actually tried redoing the install rooted at c:\texlive\2008
> and had the same failure, though.
>> The problems appear to start with:
>> [...]
>> running mktexlsr C:/Program Files/texlive/2008/texmf-var
>> running updmap-sys... updmap.bat: updmap: No appropriate script found.
>> done
>> re-running mktexlsr C:/Program Files/texlive/2008/texmf-var
>> [...]
>> After this the installer attempts to create formats, but the input files
>> also aren't found.   Maybe the ls-R files were't really generated, or
>> there is a problem with searching those files, so
> So I started removing MikTeX before reading all of your message, and that
> process was barely underway when I tried rerunning mktexlsr.  I was able to
> run mktexlsr and updmap-sys successfully at that time, so this was either
> due to MikTeX or failure of mktexlsr during install.  I also ran tlmgr and
> used it to generate formats, so things seem to be working fine now.  Sorry I
> can't nail down the problem more specifically, but thanks a lot for the
> hints!  I'll try reinstalling without MikTeX and see if it succeeds.

I have MikTeX-2.7on my XP box.  I run TL from a command shell

REM gotl.cmd -- start cmd shell with environment configured for TeX Live 2008
SET TLroot=F:\TeXLive\2008
REM SET TEXMFCNF=%TLroot%\texmf-var\web2c
PATH %TLroot%\bin\win32
PATH %PATH%;C:\Program Files\Xming\bin

My guess is that you still had a TEXINPUTS set by MikTeX, which has the
strange looking value:

C:\Documents and Settings\WhiteG>set TEXINPUTS

As long as you are careful with the environment variables you can
have TL2008 and MiKTeX-2.7 on the same system.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list