[tex-live] TEXDOCVIEW_pdf ???

Heiko Oberdiek oberdiek at uni-freiburg.de
Mon Aug 4 21:18:46 CEST 2008

On Mon, Aug 04, 2008 at 07:36:08PM +0200, Manuel Pégourié-Gonnard wrote:

> In r10073:
>         viewer_pdf  = os.getenv ("PDFVIEWER")
>         or os.getenv ("TEXDOCVIEW_pdf") or os.getenv ("TEXDOC_VIEWER_PDF"),
> and so on. I preferred giving precedence to the new names.

Environment variables that contains "TEXDOC" (or "texdoc")
are specific for "texdoc". The "new" names are generic names
that are used for many programs (e.g. PAGER). Usually the
specific names overwrite the generic ones. Therefore I would
  viewer_pdf = os.getenv("TEXDOC_VIEWER_PDF")
               or os.getenv("TEXDOCVIEW_pdf")
               or os.getenv("PDFVIEWER);

Yours sincerely
  Heiko <oberdiek at uni-freiburg.de>

More information about the tex-live mailing list