[tex-live] Install script TeX Live CD doesn't work.

George N. White III gnwiii at gmail.com
Tue May 1 14:16:40 CEST 2007

On 4/30/07, Natalie <nat at switch.demon.nl> wrote:

> Hello,
> This afternoon I downloaded the TeX Live iso image and burned it on
> CD. The md5 sum was verified, the copied data was verified too.
> I mounted the CD and did:
>   # ./install-tl.sh
> This is the output:
>   bash: ./install-tl.sh: /bin/sh: bad interpreter: Permission denied

Some systems mount CD's with noexec permissions.  I think this is mentioned
in the TL documentation.  If you are on linux, it is often easier to
mount the .iso
image directly (using the loop device) without actually creating a
physical CD-ROM.

> bash does exist in /bin
> sh is a symlink to bash
> I tried:
>   # sh
>   sh-3.1# ./install-tl.sh
> Result:
>   sh: ./install-tl.sh: /bin/sh: bad interpreter: Permission denied
> I changed back to bash.
> Then I tried to run the GUI installation
>   # cd setuptl/
>   # ./tlpm-i386-linux.pl
> Result:
>   bash: ./tlpm-i386-linux.pl: /usr/bin/env: bad interpreter:
> Permission denied
> In /usr/bin there is a file perl and a file perl5.8.7
> /usr/bin/env does exist
> Before I tried to install TeX Live, I removed the installed TeX and
> TeTeX packages (in Synaptic package manager).
> I'm using Linux, Kubuntu 6.06, KDE desktop.
> Can you please help me to make the Live installation work?

You may need to consult someone familiar with your particular linux distro
to find out how to change the mount permissions.

George N. White III <aa056 at chebucto.ns.ca>
Head of St. Margarets Bay, Nova Scotia

More information about the tex-live mailing list