[tex-live] Re: Tests with TLPM/TLPMGUI (1. Update)

George N. White III aa056 at chebucto.ns.ca
Wed Oct 5 23:17:29 CEST 2005

On Mon, 3 Oct 2005, Wolfgang Fleischer wrote:

> I did enlarge my testbed somewhat: a brand new thinkpad r52 with
> xpsp2, my long running xpsp2, a fresh xpsp2 under vmware.
> The behaviour was always the same and in some way unpredictable
> and not to understand:
> -On a clean machine TLPMGUI works as expected with one exception: the
> function 'add packages'.
> -After using TLPMGUI the first time I could not
> use 'inst' within TLPM but unist, list ...

I burned the 20051004 inst CD and put it in the reader (D:) on a WinXP 
machine after removing (I hope) all trace of previous texlive installs 
from registry and environment.  Tlpmgui loaded, but when I tried to 
perform the install I got an error indicating it couldn't find a file in 
D:\.  The file was in the setup-win32 subdirectory (sorry, didn't make a 
note of the name).  Running tlpmgui manually with a custom install worked 
for me, but I haven't had a chance to try adding or removing components.

I manually edited the WinEDT setup file to look at the value of TLROOT. It 
checks registry entires used by fptex and scans long list of directories 
for a bin\win32 subdirectory, but somehow neglects to consider \TeXLive2005!

> -When I changed the default
> settings for the target path from c:\tex to somewhat other, say
> c:\texlive, I could use TLPM even inst packages. I do not want to
> enlarge this list with all my tests and results.
> May be finally I found the problem:
> On a fresh XP the PATH is a string in the registry of type
> REG_EXPAND_SZ looking like
> %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;...
> After using TLPMGUI on that system we get a String of type REG_SZ
> with content
> c:\tex\bin\win32;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\Syste
> m32\Wbem;... This is clearly wrong and as %SystemRoot% is no longer
> expanded the whole system is working badly. After correcting the PATH
> via control panel (I put the tex path element to the end) I ended up
> with a string of type REG_EXPAND_SZ again of
> %SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;...;c:\t
> ex\bin\win32 Now TLPMGUI works fine. Adding packages is with no
> problems.
> On some of systems (not clear why) the PATH is stored in a string of
> type
> REG_SZ with correctly expanded %SystemRoot% like
> c:\windows\system32;c:\windows\system32\wben;... On those systems
> TLPMGUI will not show the problems I run in.

Interesting observation -- probably explains anomlies with other packages. 
I suspect the REG_SZ entries are the result of some previous installation 
unrelated to TeX Live 2005.

George N. White III  <aa056 at chebucto.ns.ca>

More information about the tex-live mailing list