[texhax] Missing diagnostic messages in .log (TeXLive 2008)

Ritesh Sood riteshsood at gmail.com
Sat Nov 1 01:58:21 CET 2008

Hi all,

I've upgraded from TeXLive 2007 to TeXLive 2008 recently, since I'd
been having trouble with beamer+hyperref+dvipdfmx. Needless to say,
the diagnostic messages on the command line and in the .log file have always
been a tremendous help: what package versions are being used, what config
config files are being loaded, etc.

When the recent upgrade didn't fully solve the problem, i naturally
tried looking
at the .log file ... only to find out that all but font related
diagnostics have disappeared!!
Where once beamer, pgf, hyperref, used to leave behind a long trail,
now there's practically
nothing useful.

Has some new option been added to LaTeX to turn on the messages?
some settings via the new tlmgr perhaps? Please help.....

While I'm at it, here's the trouble i'm having. The document (slides
really) compiles fine,
but  during dvi -> pdf via dvipdfmx, i see quite a few of the following blocks:

** WARNING ** Can't begin an annotation when one is pending.
** WARNING ** Interpreting special command bann (pdf:) failed.
** WARNING ** >> at page="18" position="(72.816, 79.1588)" (in PDF)
** WARNING ** >> xxx "pdf:bann<</Type/Annot/Subtype/Link/Border[0 0
0]/C[.5 .5 .5]..."
** WARNING ** >> Reading special command stopped around
>><</Type/Annot/Subtype/Link/Border[0 0 0]/C[.5 .5 .5]/A<</S/G...<<
** WARNING ** Tried to end an annotation without starting one!
** WARNING ** Interpreting special command eann (pdf:) failed.
** WARNING ** >> at page="18" position="(80.1245, 77.1663)" (in PDF)
** WARNING ** >> xxx "pdf:eann"

Searching on the web didn't return anything useful, maybe someone can
shed light on the issue.

Thanks a lot,

More information about the texhax mailing list